Bug 66687

Summary: [Meta] Support Android OS for the Chromium port
Product: WebKit Reporter: Peter Beverloo <peter@chromium.org>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth@webkit.org, acucu@adobe.com, anders.edenbrandt@sonyericsson.com, andreip@google.com, antaryami.pandia@motorola.com, arun.patole@motorola.com, ask@swva.net, benm@google.com, christian.webkit@gmail.com, dbates@webkit.org, donggwan.kim@samsung.com, efidler@rim.com, eunmi15.lee@samsung.com, fsamuel@chromium.org, gyuyoung.kim@samsung.com, gyuyoung.kim@webkit.org, ibchang@samsung.com, iserg9@gmail.com, james.wei@intel.com, jdanni@gmail.com, jesus@webkit.org, johnme@chromium.org, joone.hur@collabora.co.uk, jrg@chromium.org, kennyluck@w3.org, laszlo.gombos@webkit.org, litherum@gmail.com, ljaehun.lim@samsung.com, manveer@bitmagic.in, mathias@qiwi.be, mburtin@connected-labs.com, m.k.edwards@gmail.com, naiem.shaik@gmail.com, nayankk@motorola.com, oaduroja@lab126.com, priyajeet.hora@gmail.com, rakeshchaitan@gmail.com, rgf748@motorola.com, rniwa@webkit.org, ronald@archlinux.org, sangseok.lim@gmail.com, saugatad@gmail.com, skyul@company100.com, sriram.yadavalli@gmail.com, tomz@codeaurora.org, tonikitoo@webkit.org, tonyg@chromium.org, wonsuk11.lee@samsung.com, yfriedman@chromium.org, yoon@igalia.com, zalan@apple.com, zecke@selfish.org, zhenghao@chromium.org
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 55874, 66230, 66688, 66689, 66800, 67299, 67303, 67573, 67574, 67575, 67576, 67613, 67615, 67616, 67887, 67888, 67889, 67890, 69997, 73085, 73452, 73672, 74089, 74097, 74614, 78524, 78547, 78656, 78745, 78855, 78862, 78864, 78971, 78973, 79117, 79150, 79167, 79222, 80554, 80852, 82461, 82566, 82949, 83959, 84385, 84400, 84517, 84843, 84936, 85725, 85842, 85867, 85869, 85897, 85958, 86030, 86040, 86041, 86045, 86147, 86149, 86270, 86440, 86573, 86819, 86862, 87006, 87035, 87036, 87058, 87087, 87095, 87164, 87176, 87407, 87440, 87545, 87710, 87773, 88053, 88057, 88068, 88147, 88266, 88270, 88375, 88527, 88533, 88598, 88684, 88762, 88775, 88802, 88806, 88837, 88897, 88999, 89025, 89044, 89098, 89124, 89133, 89228, 89392, 89398, 89406, 89428, 89718, 89720, 89721, 89788, 89801, 89849, 89856, 89910, 90210, 90219, 90222, 90292, 90296, 90309, 90498, 90826, 90831, 90918, 90920, 90921, 90989, 90991, 91102, 91110, 91240, 91291, 91428, 91533, 91550, 91648, 91674, 92117, 92126, 92132, 92308, 92513, 92653, 92698, 92737, 92858, 92900, 92921, 92931, 92997, 93111, 93514, 93627, 93724, 93998, 94182, 94727, 95679, 95690, 96112, 98173, 98671, 99656    
Bug Blocks:    

Description From 2011-08-22 11:06:27 PST
The Android Browser has come to a point where it shares enough code with Chrome to entirely reuse the Chromium port of WebKit.

This bug will serve as a meta-bug to track progress of our upstreaming effort.
------- Comment #1 From 2011-08-29 23:48:14 PST -------
Why did we add a Android bot as a core builder in http://trac.webkit.org/changeset/93946?  As I understand it, new bot should be added as non-core before it can be promoted to a core builder.
------- Comment #2 From 2011-08-30 01:28:50 PST -------
Sounds like a bug, probably in the regexp.  Android should not yet be a core builder.
------- Comment #3 From 2011-10-06 04:48:22 PST -------
*** Bug 60907 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2012-05-07 16:29:21 PST -------
Re-opened since this is blocked by 85842
------- Comment #5 From 2012-05-07 23:46:52 PST -------
Re-opened since this is blocked by 85867
------- Comment #6 From 2012-05-08 00:09:38 PST -------
Re-opened since this is blocked by 85869
------- Comment #7 From 2012-05-08 10:36:04 PST -------
Re-opened since this is blocked by 85897
------- Comment #8 From 2012-11-06 09:59:55 PST -------
Marking this as fixed. Chromium for Android has been completely upstreamed, and is now fully supported in WebKit.

http://lists.webkit.org/pipermail/webkit-dev/2012-November/022743.html