Bug 31863 - [Qt] Enable access to WebKit's JavaScript environment with the QtScript API.
: [Qt] Enable access to WebKit's JavaScript environment with the QtScript API.
Status: RESOLVED WONTFIX
: WebKit
JavaScriptCore
: 528+ (Nightly build)
: All All
: P3 Enhancement
Assigned To:
:
: Qt, QtTriaged
: 32565 34533 34575 34592 34749 34793 34843 34847 34850 35387 35577 35578 35968 36008 36123 36594 36600 36603 36650 37596 37598 37610 37617 37729 37953 38110 38112 39114 39115 39356 40058 40067 40110 40114 40120 40412 40415 40903 40911 41199 41520 41598 41662 41664 41665 41666 41667 41668 41672 41673 41674 41675 41676 41677 41678 41680 41681 41683 41713 41769 41839 42363 42364 42366 43038 43115
: 23250 24102 30556
  Show dependency treegraph
 
Reported: 2009-11-25 01:41 PST by
Modified: 2011-07-07 07:57 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-25 01:41:45 PST
This allows developers to easily expose new JavaScript APIs to WebKit, without having to change WebKit or to use a NPAPI plugin. For example, bindings to an existing C++ library could be made available in WebKit.
------- Comment #1 From 2009-11-25 01:42:06 PST -------
The high-level requirements are tracked at http://bugreports.qt.nokia.com/browse/QTWEBKIT-2
------- Comment #2 From 2009-11-25 01:42:30 PST -------
*** Bug 29877 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2009-11-26 01:50:17 PST -------
*** Bug 23250 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2009-12-15 06:59:20 PST -------
It is time to start, as it was discussed on dev mailing list (https://lists.webkit.org/pipermail/webkit-dev/2009-August/009610.html), it would be really great to have Qtish API over JSC. We considered all hints and suggestions and we decided to create a new QtScript like API on top of JSC's __public__ C API. We would like to start developing in the WebKit repository from the very beginning to avoid any confusion and make our development process transparent.

I would like to keep the bug (31863) as a meta-bug. All other development bugs should be connected to this one as a blockers.

Roadmap:
1. Create a small QJavaScript API.
  a) The API should provide enough functionality to be useful (run scripts, call functions, convert basic data...)
  b) The API implementation should be simple, all optimization work should be started after the API review
2. Change the building system - QtJavaScript and JSC should be build as a shared library (bug 27551)
3. Connect the new API to the QtWebkit API
4. Add new features
------- Comment #5 From 2010-07-27 23:52:32 PST -------
(In reply to comment #4)
Previous comment is a bit outdated. We decided to not create a new API, but instead move the QtScript implementation over JSC C API.

The current roadmap can be found here:
http://bugreports.qt.nokia.com/browse/QTBUG-11464
------- Comment #6 From 2011-04-07 14:20:35 PST -------
This work is "paused" and we are exploring other options, more details in http://developer.qt.nokia.com/wiki/Category:Developing_Qt::Qt_Script
------- Comment #7 From 2011-07-07 07:57:00 PST -------
Porting QtScript API over JSC C API will not be continued.

Bug numeber for code cleanup related work: 64088