Bug 39259 - MASTER: WebKit needs an HTML5 Tokenizer
: MASTER: WebKit needs an HTML5 Tokenizer
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: WebCore Misc.
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
:
Depends on: 39260 39261 39262 39263 39264 39265 39267 39272 39273 39274 39275 39298 39311 39333 39334 39335 39342 39345 39349 39350 39520 39525 39533 39534 39537 39571 39623 39630 39638 39641 39642 39649 39653 39660 39716 39755 39796 39802 39809 39815 39823 39828 39873 39891 39939 39981 39982 39984 39985 40048 40172 40199 40200 40262 40264 40265 40268 40274 40282 40283 40284 40311 40347 40354 40356 40384 40385 40388 40391 40393 40404 40406 40416 40417 40428 40454 40458 40485 40491 40557 40592 40596 40638 40645 40649 40650 40657 40658 40659 40664 40726 40729 40739 40764 40802 40946
Blocks: 32934 30388
  Show dependency treegraph
 
Reported: 2010-05-17 19:57 PDT by Eric Seidel
Modified: 2011-05-17 10:54 PDT (History)
22 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel 2010-05-17 19:57:07 PDT
MASTER: WebKit needs an HTML5 Tokenizer

Adam and I are going to work on adding one this week.  This is a master bug which we will relate all of the various bugs to.

We're going to start by forking from PreloadScanner.  We will be in #webkit and happy to discuss our design thoughts.
Comment 1 Adam Barth 2010-05-20 09:51:54 PDT
Henri mentioned that Mozilla has 6 open evangelism related to their HTML5 parser:

http://www.w3.org/Bugs/Public/show_bug.cgi?id=9767#c3
Comment 2 Adam Barth 2010-06-04 21:03:27 PDT
Here's the spreadsheet we're using to triage the remaining LayoutTest failures:

https://spreadsheets.google.com/ccc?key=0AppchfQ5mBrEdDFJUW5DOGNsdmtvZkN0ZmIzMjdaT0E&hl=en

Currently, there are around 150 failures.  However, for some of them, our new behavior is correct w.r.t. the spec but the tests have their expectations set to the old parser behavior.
Comment 3 Adam Barth 2010-06-16 02:23:43 PDT
This is now enabled by default.  There are still some dependent bugs to finish up, but we can close the master.  We'll probably open a new master to deal with regressions.
Comment 4 Adam Barth 2010-06-23 17:48:16 PDT
Here's the master bug for tracking compatibility regressions due to the new tokenizer:

https://bugs.webkit.org/show_bug.cgi?id=41115
Comment 5 Eric Seidel 2011-05-17 10:54:12 PDT
*** Bug 40634 has been marked as a duplicate of this bug. ***