Bug 50995

Summary: Flaky Test: fast/workers/storage/use-same-database-in-page-and-workers.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: adamk, dslomov, dumi, eric, levin, michaeln, webkit.review.bot, zhenghao
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on: 75111    
Bug Blocks: 50856    
Attachments:
Description Flags
Archive of layout-test-results from eseidel-sf-cq
none
Failure diff from eseidel-cq-sf
none
Failure diff from eseidel-cq-sf
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-7
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-8
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-7
none
Failure diff from cr-jail-7
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-3
none
Failure diff from cr-jail-8 none

Description WebKit Commit Bot 2010-12-13 16:51:15 PST
This is an automatically generated bug from the commit-queue.
fast/workers/storage/use-same-database-in-page-and-workers.html has been flaky on the commit-queue.

fast/workers/storage/use-same-database-in-page-and-workers.html was authored by dumi@chromium.org.
http://trac.webkit.org/browser/trunk/LayoutTests/fast/workers/storage/use-same-database-in-page-and-workers.html

The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76453 [details] on bug 50988.
Bot: eseidel-cq-sl  Port: Mac  Platform: Mac OS X 10.6.5

The bots will update this with information from each new failure.

If you would like to track this test fix with another bug, please close this bug as a duplicate.
Comment 1 Eric Seidel (no email) 2010-12-13 23:46:06 PST
*** Bug 51003 has been marked as a duplicate of this bug. ***
Comment 2 WebKit Commit Bot 2010-12-14 05:14:41 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76523 [details] on bug 51023.
Bot: eseidel-cq-sl  Port: Mac  Platform: Mac OS X 10.6.5
Comment 3 WebKit Commit Bot 2010-12-14 05:38:01 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76523 [details] on bug 51023.
Bot: eseidel-cq-sl  Port: Mac  Platform: Mac OS X 10.6.5
Comment 4 WebKit Commit Bot 2010-12-14 09:11:29 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76535 [details] on bug 51037.
Bot: eseidel-cq-sl  Port: Mac  Platform: Mac OS X 10.6.5
Comment 5 WebKit Commit Bot 2010-12-16 16:06:10 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76787 [details] on bug 51160.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4
Comment 6 Eric Seidel (no email) 2010-12-16 16:41:23 PST
This may be a timeout or crash since the cq hasn't uploaded any results for it yet.  Sadly our reporting code isn't good enough at conveying that on the bug yet.
Comment 7 WebKit Commit Bot 2010-12-17 02:56:32 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76854 [details] on bug 51236.
Bot: abarth-cq-sl  Port: Mac  Platform: Mac OS X 10.6.5
Comment 8 WebKit Commit Bot 2010-12-24 10:19:00 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 77418 [details] on bug 28291.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4
Comment 9 WebKit Commit Bot 2010-12-24 10:54:25 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 77286 [details] on bug 27753.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 10 WebKit Commit Bot 2010-12-24 10:58:21 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 77330 [details] on bug 51535.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 11 WebKit Commit Bot 2010-12-28 10:54:25 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 76776 [details] on bug 50971.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 12 WebKit Commit Bot 2010-12-29 12:38:44 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake while processing attachment 77591 [details] on bug 51067.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 13 WebKit Commit Bot 2011-01-08 17:29:11 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 78266 [details] on bug 52081.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 14 WebKit Commit Bot 2011-01-08 18:53:51 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 78288 [details] on bug 51982.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4
Comment 15 WebKit Commit Bot 2011-01-10 06:38:26 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 77717 [details] on bug 51776.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 16 WebKit Commit Bot 2011-01-10 18:24:16 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 78408 [details] on bug 51253.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
Comment 17 WebKit Commit Bot 2011-01-11 04:43:48 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 76977 [details] on bug 51237.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4
Comment 18 WebKit Commit Bot 2011-01-11 15:17:06 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 78578 [details] on bug 52239.
Bot: eseidel-sf-cq  Port: Mac  Platform: Mac OS X 10.6.4
Comment 19 WebKit Commit Bot 2011-01-11 15:17:08 PST
Created attachment 78608 [details]
Archive of layout-test-results from eseidel-sf-cq
Comment 20 WebKit Commit Bot 2011-01-11 15:47:05 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 78487 [details] on bug 50182.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4
Comment 21 Eric Seidel (no email) 2011-01-11 18:03:04 PST
Comment on attachment 78608 [details]
Archive of layout-test-results from eseidel-sf-cq

Clearly there is a bug in the zip uploading code.  Investigating.
Comment 22 Eric Seidel (no email) 2011-01-11 23:38:10 PST
I believe the upload behavior to be fixed in http://trac.webkit.org/changeset/75583.  Sorry for the noise.  The next flake should give us results.
Comment 23 WebKit Commit Bot 2011-02-07 04:34:19 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 81231 [details] on bug 53775.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 24 WebKit Commit Bot 2011-02-07 04:34:22 PST
Created attachment 81466 [details]
Failure diff from eseidel-cq-sf
Comment 25 WebKit Commit Bot 2011-02-14 11:43:18 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 82330 [details] on bug 54333.
Bot: eseidel-cq-sf  Port: Mac  Platform: Mac OS X 10.6.4
Comment 26 WebKit Commit Bot 2011-02-14 11:43:21 PST
Created attachment 82344 [details]
Failure diff from eseidel-cq-sf
Comment 27 WebKit Commit Bot 2011-03-16 22:55:05 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 85986 [details] on bug 56414.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 28 WebKit Commit Bot 2011-03-16 22:55:08 PDT
Created attachment 86029 [details]
Failure diff from cr-jail-3
Comment 29 WebKit Commit Bot 2011-03-25 12:29:36 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 86858 [details] on bug 57062.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 30 WebKit Commit Bot 2011-03-25 12:29:39 PDT
Created attachment 86972 [details]
Failure diff from cr-jail-3
Comment 31 WebKit Commit Bot 2011-03-28 22:38:35 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 86935 [details] on bug 57022.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
Comment 32 WebKit Commit Bot 2011-03-28 22:38:38 PDT
Created attachment 87261 [details]
Failure diff from cr-jail-7
Comment 33 WebKit Commit Bot 2011-03-28 23:30:42 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 87119 [details] on bug 57142.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 34 WebKit Commit Bot 2011-03-28 23:30:45 PDT
Created attachment 87267 [details]
Failure diff from cr-jail-3
Comment 35 WebKit Commit Bot 2011-03-29 10:32:59 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 87333 [details] on bug 56602.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
Comment 36 WebKit Commit Bot 2011-03-29 10:33:02 PDT
Created attachment 87360 [details]
Failure diff from cr-jail-8
Comment 37 WebKit Commit Bot 2011-03-29 11:57:47 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 87316 [details] on bug 57338.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 38 WebKit Commit Bot 2011-03-29 11:57:50 PDT
Created attachment 87383 [details]
Failure diff from cr-jail-3
Comment 39 WebKit Commit Bot 2011-03-31 12:27:10 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 87712 [details] on bug 57017.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
Comment 40 WebKit Commit Bot 2011-03-31 12:27:12 PDT
Created attachment 87776 [details]
Failure diff from cr-jail-7
Comment 41 WebKit Commit Bot 2011-04-05 02:26:10 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 88139 [details] on bug 57664.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
Comment 42 WebKit Commit Bot 2011-04-05 02:26:13 PDT
Created attachment 88193 [details]
Failure diff from cr-jail-7
Comment 43 WebKit Commit Bot 2011-04-11 13:43:07 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 88876 [details] on bug 58143.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 44 WebKit Commit Bot 2011-04-11 13:43:10 PDT
Created attachment 89072 [details]
Failure diff from cr-jail-3
Comment 45 WebKit Commit Bot 2011-04-28 17:08:10 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 90704 [details] on bug 53031.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
Comment 46 WebKit Commit Bot 2011-04-28 17:08:13 PDT
Created attachment 91596 [details]
Failure diff from cr-jail-3
Comment 47 Eric Seidel (no email) 2011-04-28 17:35:44 PDT
This seems to be failing quite often.  Any theories?
Comment 48 David Levin 2011-04-28 17:42:47 PDT
Adding others who may be maintaining database related items.
Comment 49 WebKit Commit Bot 2011-04-29 18:58:40 PDT
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 91762 [details] on bug 58378.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
Comment 50 WebKit Commit Bot 2011-04-29 18:58:44 PDT
Created attachment 91791 [details]
Failure diff from cr-jail-8
Comment 51 WebKit Review Bot 2012-02-29 22:12:21 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 129530 [details] on bug 79145.
Bot: ec2-cq-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 52 WebKit Review Bot 2012-03-01 00:12:23 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 129549 [details] on bug 79855.
Bot: ec2-cq-03  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 53 WebKit Review Bot 2012-03-01 03:41:18 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 129631 [details] on bug 80004.
Bot: ec2-cq-01  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 54 WebKit Review Bot 2012-03-01 04:35:41 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 129640 [details] on bug 80008.
Bot: ec2-cq-02  Port: Chromium  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 55 WebKit Review Bot 2012-03-01 05:59:02 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 129663 [details] on bug 77522.
Bot: ec2-cq-03  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 56 David Levin 2012-03-01 09:23:17 PST
I think this test should just be disabled (and someone should look into it because something seems really wrong here).

It is failing so much that it is getting perfectly good patches rejected from the commit queue.
Comment 57 David Levin 2012-03-01 09:25:06 PST
Looks like https://bugs.webkit.org/show_bug.cgi?id=75111 is related.
Comment 58 WebKit Review Bot 2012-03-01 09:49:22 PST
The commit-queue just saw fast/workers/storage/use-same-database-in-page-and-workers.html flake (Text diff mismatch) while processing attachment 129688 [details] on bug 79929.
Bot: ec2-cq-01  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 59 Michael Nordman 2012-03-01 16:28:47 PST
David, in recent history, is this giving us grief for v8 ports only or should we disable this test for all ports across the board? 'ChromiumXVFBPort' makes me think the former.

What happened on 2012-02-29? Prior to that date, there hadn't been a report of this since 2011-04-29.
Comment 60 Eric Seidel (no email) 2012-03-01 16:31:40 PST
The commit-queue forgot how to report flaky tests for several months. :)  It miraculously remembered recently.
Comment 61 Michael Nordman 2012-03-01 16:46:37 PST
(In reply to comment #60)
> The commit-queue forgot how to report flaky tests for several months. :)  It miraculously remembered recently.

How many is several, did the amnesia start before or after 2011-04-29? And how recent is recently, revision number?

This looks like something that happened on 2012-02-29 that could be related.
http://trac.webkit.org/changeset/109319
Comment 62 Eric Seidel (no email) 2012-03-01 16:49:36 PST
(In reply to comment #61)
> (In reply to comment #60)
> > The commit-queue forgot how to report flaky tests for several months. :)  It miraculously remembered recently.
> 
> How many is several, did the amnesia start before or after 2011-04-29? And how recent is recently, revision number?
> 
> This looks like something that happened on 2012-02-29 that could be related.
> http://trac.webkit.org/changeset/109319

From https://bugs.webkit.org/show_activity.cgi?id=50856 it looks like the CQ forgot how to report flaky tests around last July, and started again on Valentines day.
Comment 63 Eric Seidel (no email) 2012-03-01 16:49:53 PST
We may disable this feature entirely.  I'm not sure it's providing value.
Comment 64 Michael Nordman 2012-03-01 17:03:01 PST
Thnx for the dates... there's a buffer of a couple of months before amnesia set in, and a few weeks after recovery where this wasn't flaking/crashing on us. Seems like the db related patch on 2/29 may be related in some unanticipated way?

I'll take a look at that patch and see if anything looks interesting.

I can also take a loot at modifying the canInvokeCallback() method for this particular class &| making a custom binding for this that doesn't call CRASH (as mentioned in https://bugs.webkit.org/show_bug.cgi?id=75111)

It'd probably be good to skip this test in the interim.
Comment 65 David Levin 2012-03-01 18:03:58 PST
(In reply to comment #64)
> Thnx for the dates... there's a buffer of a couple of months before amnesia set in, and a few weeks after recovery where this wasn't flaking/crashing on us. Seems like the db related patch on 2/29 may be related in some unanticipated way?
> 
> I'll take a look at that patch and see if anything looks interesting.
> 
> I can also take a loot at modifying the canInvokeCallback() method for this particular class &| making a custom binding for this that doesn't call CRASH (as mentioned in https://bugs.webkit.org/show_bug.cgi?id=75111)
> 
> It'd probably be good to skip this test in the interim.

Here's a better indicator for when this test fell over: http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=use-same-database-in-page-and-workers.html

Looks like it is only Linux and started happening http://trac.webkit.org/log/?verbose=on&rev=109304&stop_rev=109297

When a result was added for it? (Maybe not so helpful.)
Comment 66 Dmitry Lomov 2012-03-01 18:25:03 PST
(In reply to comment #65)
> (In reply to comment #64)
> > Thnx for the dates... there's a buffer of a couple of months before amnesia set in, and a few weeks after recovery where this wasn't flaking/crashing on us. Seems like the db related patch on 2/29 may be related in some unanticipated way?
> > 
> > I'll take a look at that patch and see if anything looks interesting.
> > 
> > I can also take a loot at modifying the canInvokeCallback() method for this particular class &| making a custom binding for this that doesn't call CRASH (as mentioned in https://bugs.webkit.org/show_bug.cgi?id=75111)
> > 
> > It'd probably be good to skip this test in the interim.
> 
> Here's a better indicator for when this test fell over: http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=use-same-database-in-page-and-workers.html
> 
> Looks like it is only Linux and started happening http://trac.webkit.org/log/?verbose=on&rev=109304&stop_rev=109297
> 
> When a result was added for it? (Maybe not so helpful.)

Rats, it looks like the wrong result was added (without a PASS in the end).
The test still times out.
Comment 67 Michael Nordman 2012-03-01 18:39:09 PST
Oh... that's what happened on 2/29... the results of a timed out test were added as the expected results on linux... pretty funny :)

That patch should be reverted.
Comment 68 Hao Zheng 2012-03-01 18:40:48 PST
(In reply to comment #64)
> Thnx for the dates... there's a buffer of a couple of months before amnesia set in, and a few weeks after recovery where this wasn't flaking/crashing on us. Seems like the db related patch on 2/29 may be related in some unanticipated way?
> 
> I'll take a look at that patch and see if anything looks interesting.
> 
> I can also take a loot at modifying the canInvokeCallback() method for this particular class &| making a custom binding for this that doesn't call CRASH (as mentioned in https://bugs.webkit.org/show_bug.cgi?id=75111)
> 
> It'd probably be good to skip this test in the interim.

I'm afraid skipping this single test is not enough. I saw that several other tests related to WebWorker flakily crash when timing out on our downstream Android bot, and all are caused by the same issue:
fast/workers/worker-navigator.html = CRASH
http/tests/websocket/tests/hybi/workers/close-in-worker.html = CRASH
fast/workers/storage/open-database-set-empty-version-sync.html = CRASH
http/tests/filesystem/workers/resolve-url.html = CRASH
http/tests/websocket/tests/hybi/workers/close-in-onmessage-crash.html = CRASH

We don't see other crash on public bots just because they don't timeout as frequently as on Android.
Comment 69 David Levin 2012-03-01 18:42:13 PST
(In reply to comment #68)
> 
> I'm afraid skipping this single test is not enough. I saw that several other tests related to WebWorker flakily crash when timing out on our downstream Android bot, and all are caused by the same issue:
> fast/workers/worker-navigator.html = CRASH
> http/tests/websocket/tests/hybi/workers/close-in-worker.html = CRASH
> fast/workers/storage/open-database-set-empty-version-sync.html = CRASH
> http/tests/filesystem/workers/resolve-url.html = CRASH
> http/tests/websocket/tests/hybi/workers/close-in-onmessage-crash.html = CRASH
> 
> We don't see other crash on public bots just because they don't timeout as frequently as on Android.

At the moment, I've mostly been concerned with how this is affecting our commit queue (which is why I wanted it skipped).
Comment 70 Michael Nordman 2012-03-01 18:48:12 PST
Do you know if those if the proximate cause of those crashes is also a v8 binding induced CRASH() like the one in the database case? In the db case, the CRASH() call seems like an overly aggressive response to what happening in the case.

> fast/workers/worker-navigator.html = CRASH
> http/tests/websocket/tests/hybi/workers/close-in-worker.html = CRASH
> fast/workers/storage/open-database-set-empty-version-sync.html = CRASH
> http/tests/filesystem/workers/resolve-url.html = CRASH
> http/tests/websocket/tests/hybi/workers/close-in-onmessage-crash.html = CRASH
> 
> We don't see other crash on public bots just because they don't timeout as frequently as on Android.


@david, seems like reverting http://trac.webkit.org/changeset/109303/ would make the cq a lot better.
Comment 71 Hao Zheng 2012-03-01 18:49:57 PST
(In reply to comment #69)
> (In reply to comment #68)
> > 
> > I'm afraid skipping this single test is not enough. I saw that several other tests related to WebWorker flakily crash when timing out on our downstream Android bot, and all are caused by the same issue:
> > fast/workers/worker-navigator.html = CRASH
> > http/tests/websocket/tests/hybi/workers/close-in-worker.html = CRASH
> > fast/workers/storage/open-database-set-empty-version-sync.html = CRASH
> > http/tests/filesystem/workers/resolve-url.html = CRASH
> > http/tests/websocket/tests/hybi/workers/close-in-onmessage-crash.html = CRASH
> > 
> > We don't see other crash on public bots just because they don't timeout as frequently as on Android.
> 
> At the moment, I've mostly been concerned with how this is affecting our commit queue (which is why I wanted it skipped).

Sure. Sounds good to me.
Comment 72 Hao Zheng 2012-03-01 18:50:38 PST
(In reply to comment #70)
> Do you know if those if the proximate cause of those crashes is also a v8 binding induced CRASH() like the one in the database case? In the db case, the CRASH() call seems like an overly aggressive response to what happening in the case.

Yes, I confirm.
Comment 73 Michael Nordman 2012-03-01 19:02:59 PST
> Yes, I confirm.

The suicidal CRASH() seems too harsh for this condition. As I understand it, The c++ object has outlived it's v8 split personality (not really unexpected since the c++ obj is refcounted independently), the c++ guy tries to poke its v8 peer and CRASH() is intentionally invoked in the bindings layer as the outgoing poke is being performed. Why does that condition warrant a CRASH?
Comment 74 Dmitry Lomov 2012-03-02 11:40:48 PST
(In reply to comment #73)
> > Yes, I confirm.
> 
> The suicidal CRASH() seems too harsh for this condition. As I understand it, The c++ object has outlived it's v8 split personality (not really unexpected since the c++ obj is refcounted independently), 

This is definitely not expected. v8 objects maintain a "ref ptr" to c++ object.

> the c++ guy tries to poke its v8 peer and CRASH() is intentionally invoked in the bindings layer as the outgoing poke is being performed. Why does that condition warrant a CRASH?
Comment 75 Michael Nordman 2012-03-02 13:31:38 PST
(In reply to comment #74)
> (In reply to comment #73)
> > > Yes, I confirm.
> > 
> > The suicidal CRASH() seems too harsh for this condition. As I understand it, The c++ object has outlived it's v8 split personality (not really unexpected since the c++ obj is refcounted independently), 
> 
> This is definitely not expected. v8 objects maintain a "ref ptr" to c++ object.

really... v8 obj goes away releasing "a" ref on the c++ guy, but not the final ref)... c++ obj still hanging around... what's not to be expected about that?

See comments just added to https://bugs.webkit.org/show_bug.cgi?id=75111 about a proposed fix for this class of bugs
Comment 76 Dmitry Lomov 2012-03-02 13:36:12 PST
(In reply to comment #75)
> (In reply to comment #74)
> > (In reply to comment #73)
> > > > Yes, I confirm.
> > > 
> > > The suicidal CRASH() seems too harsh for this condition. As I understand it, The c++ object has outlived it's v8 split personality (not really unexpected since the c++ obj is refcounted independently), 
> > 
> > This is definitely not expected. v8 objects maintain a "ref ptr" to c++ object.
> 
> really... v8 obj goes away releasing "a" ref on the c++ guy, but not the final ref)... c++ obj still hanging around... what's not to be expected about that?

v8 objects don't go away until their C++ objects go away. We are in termination conditions here where this does not hold though.
> 
> See comments just added to https://bugs.webkit.org/show_bug.cgi?id=75111 about a proposed fix for this class of bugs
Comment 77 Michael Nordman 2012-03-07 15:24:44 PST

*** This bug has been marked as a duplicate of bug 75111 ***