Bug 70559 - [Chromium] Implement Viewport Meta tag and Fixed Layout
Summary: [Chromium] Implement Viewport Meta tag and Fixed Layout
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Fady Samuel
URL:
Keywords:
: 67859 (view as bug list)
Depends on: 64290 70553 70561 70562 74014 77433 45652 68617 69136 70459 70507 70519 70552 70555 70556 70558 70609 70614 70632 71198 71485 71622 72176 72983 73495 74155 75556 75601 77429 77431 77435 77436 80554 81940 82757
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 15:48 PDT by Fady Samuel
Modified: 2013-04-11 11:46 PDT (History)
9 users (show)

See Also:


Attachments
Patch (25.84 KB, patch)
2011-11-03 15:26 PDT, Fady Samuel
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fady Samuel 2011-10-20 15:48:28 PDT
Master bug to track progress and related issues
Comment 1 Fady Samuel 2011-10-21 08:21:59 PDT
(In reply to comment #0)
> Master bug to track progress and related issues

Links of interest (I may refer to this pages in the future in during code reviews):


http://quirksmode.org/mobile/tableViewport.html
http://mobilehtml5.org/
http://www.w3.org/TR/CSS21/syndata.html#pixel-units
http://developer.android.com/guide/webapps/targeting.html
http://dev.w3.org/csswg/css-device-adapt/
Comment 2 Fady Samuel 2011-10-25 15:45:19 PDT
*** Bug 67859 has been marked as a duplicate of this bug. ***
Comment 3 Fady Samuel 2011-11-03 15:26:51 PDT
Created attachment 113566 [details]
Patch
Comment 4 Fady Samuel 2011-11-03 15:29:04 PDT
I've uploaded a patch of the changes I have locally for reference and discussion only, and not for review. I'm working on a web page with a series of viewport tests that can be run on any device with an internet connection. Will be available with detailed descriptions of what they're testing within a few days. 

Chromium render side fo the changes can be found here: http://codereview.chromium.org/7831028