Bug 45652 - LayoutTestController.dumpConfigurationForViewport should move to Internals
Summary: LayoutTestController.dumpConfigurationForViewport should move to Internals
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Adam Barth
URL:
Keywords:
: 89984 (view as bug list)
Depends on:
Blocks: 72722 70559
  Show dependency treegraph
 
Reported: 2010-09-13 04:26 PDT by Pavel Podivilov
Modified: 2012-07-10 06:23 PDT (History)
15 users (show)

See Also:


Attachments
Mark new viewport tests as failing rather then skip them (1.49 KB, patch)
2010-09-15 04:20 PDT, Pavel Podivilov
no flags Details | Formatted Diff | Diff
work in progress (25.78 KB, patch)
2012-07-09 15:52 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (232.51 KB, patch)
2012-07-09 17:36 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (244.07 KB, patch)
2012-07-09 18:10 PDT, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Podivilov 2010-09-13 04:26:29 PDT
[Chromium] viewport meta tag tests are failing

http://trac.webkit.org/changeset/67376
Comment 1 Kenneth Rohde Christiansen 2010-09-13 05:44:34 PDT
Some of the tests are currently skipped for Qt as they do not give the same result as on the iPhone according to the Opera guys.
Comment 2 Kenneth Rohde Christiansen 2010-09-13 06:26:05 PDT
Thanks Pavel for skipping the tests so far.
Comment 3 Pavel Podivilov 2010-09-15 04:20:52 PDT
Created attachment 67664 [details]
Mark new viewport tests as failing rather then skip them
Comment 4 Yury Semikhatsky 2010-09-15 04:34:52 PDT
Comment on attachment 67664 [details]
Mark new viewport tests as failing rather then skip them

Clearing flags on attachment: 67664

Committed r67548: <http://trac.webkit.org/changeset/67548>
Comment 5 Yury Semikhatsky 2010-09-15 04:35:05 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Pavel Podivilov 2010-09-15 04:36:50 PDT
resolved -> unconfirmed
Comment 7 Mihai Parparita 2011-03-07 12:53:37 PST
Re-titling bug since it's a missing DRT/LayoutTestController feature.
Comment 8 Adam Barth 2012-07-09 15:41:07 PDT
The madness must end.
Comment 9 Adam Barth 2012-07-09 15:52:42 PDT
Created attachment 151336 [details]
work in progress
Comment 10 Adam Barth 2012-07-09 17:36:49 PDT
Created attachment 151367 [details]
Patch
Comment 11 Adam Barth 2012-07-09 17:41:16 PDT
Comment on attachment 151367 [details]
Patch

Actually, this patch will fail test 91.  One sec.
Comment 12 Build Bot 2012-07-09 17:43:36 PDT
Comment on attachment 151367 [details]
Patch

Attachment 151367 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13164428
Comment 13 Build Bot 2012-07-09 17:54:03 PDT
Comment on attachment 151367 [details]
Patch

Attachment 151367 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/13164432
Comment 14 Adam Barth 2012-07-09 18:10:51 PDT
Created attachment 151374 [details]
Patch
Comment 15 Eric Seidel (no email) 2012-07-10 00:33:27 PDT
Comment on attachment 151374 [details]
Patch

LGTM.
Comment 16 Adam Barth 2012-07-10 00:36:06 PDT
Thanks for the review.
Comment 17 WebKit Review Bot 2012-07-10 00:56:16 PDT
Comment on attachment 151374 [details]
Patch

Clearing flags on attachment: 151374

Committed r122204: <http://trac.webkit.org/changeset/122204>
Comment 18 WebKit Review Bot 2012-07-10 00:56:24 PDT
All reviewed patches have been landed.  Closing bug.
Comment 19 Csaba Osztrogonác 2012-07-10 03:25:22 PDT
(In reply to comment #17)
> (From update of attachment 151374 [details])
> Clearing flags on attachment: 151374
> 
> Committed r122204: <http://trac.webkit.org/changeset/122204>

You missed to update a test - I did it: https://trac.webkit.org/changeset/122210
Comment 20 Konrad Piascik 2012-07-10 06:23:09 PDT
*** Bug 89984 has been marked as a duplicate of this bug. ***