Bug 51138 - Flaky Test: media/invalid-media-url-crash.html
: Flaky Test: media/invalid-media-url-crash.html
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: Other Mac OS X 10.5
: P1 Normal
Assigned To:
:
: NeedsRadar
:
: 50856
  Show dependency treegraph
 
Reported: 2010-12-15 15:09 PST by
Modified: 2011-04-24 06:24 PST (History)


Attachments
Archive of layout-test-results from cr-jail-7 (22 bytes, application/zip)
2011-02-02 21:00 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (22 bytes, application/zip)
2011-02-04 16:26 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-3 (22 bytes, application/zip)
2011-02-15 21:04 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (6.39 KB, application/zip)
2011-02-17 09:40 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (6.39 KB, application/zip)
2011-02-17 11:25 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (6.38 KB, application/zip)
2011-02-18 19:02 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-7 (6.38 KB, application/zip)
2011-02-18 19:11 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-7 (6.38 KB, application/zip)
2011-02-22 22:52 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-3 (6.38 KB, application/zip)
2011-02-24 04:50 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (6.38 KB, application/zip)
2011-02-24 07:20 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-3 (6.38 KB, application/zip)
2011-02-24 09:19 PST, WebKit Commit Bot
no flags Details
crash report from local run (32.36 KB, text/plain)
2011-02-24 15:35 PST, Eric Seidel
no flags Details
Archive of layout-test-results from cr-jail-8 (6.38 KB, application/zip)
2011-02-28 16:58 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-3 (6.38 KB, application/zip)
2011-03-01 05:05 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (28.14 KB, application/zip)
2011-03-07 17:49 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (17.98 KB, application/zip)
2011-03-23 10:57 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-7 (18.30 KB, application/zip)
2011-03-23 12:36 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (29.84 KB, application/zip)
2011-04-05 09:54 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-8 (18.18 KB, application/zip)
2011-04-05 19:36 PST, WebKit Commit Bot
no flags Details
Patch (1.42 KB, patch)
2011-04-15 07:26 PST, Eric Seidel
no flags Review Patch | Details | Formatted Diff | Diff
Patch for landing (1.46 KB, patch)
2011-04-15 07:31 PST, Eric Seidel
no flags Review Patch | Details | Formatted Diff | Diff
Archive of layout-test-results from cr-jail-4 (207.91 KB, application/zip)
2011-04-16 02:09 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-7 (213.20 KB, application/zip)
2011-04-18 21:26 PST, WebKit Commit Bot
no flags Details
Archive of layout-test-results from cr-jail-7 (212.93 KB, application/zip)
2011-04-19 20:32 PST, WebKit Commit Bot
no flags Details
Patch (1.17 KB, patch)
2011-04-22 09:57 PST, Eric Seidel
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-12-15 15:09:21 PST
This is an automatically generated bug from the commit-queue.
media/invalid-media-url-crash.html has been flaky on the commit-queue.

media/invalid-media-url-crash.html was authored by inferno@chromium.org.
http://trac.webkit.org/browser/trunk/LayoutTests/media/invalid-media-url-crash.html

The commit-queue just saw media/invalid-media-url-crash.html flake while processing attachment 76685 [details] on bug 51085.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4

The bots will update this with information from each new failure.

If you would like to track this test fix with another bug, please close this bug as a duplicate.
------- Comment #1 From 2010-12-15 15:12:36 PST -------
It crashed actually:
http://queues.webkit.org/results/7097040
media/invalid-media-url-crash.html -> crashed

It's unfortunate that we don't have a good way to have it upload crash reports yet. :(
------- Comment #2 From 2010-12-27 10:45:34 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake while processing attachment 77356 [details] on bug 51225.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
------- Comment #3 From 2011-01-06 17:52:04 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (Test shell crashed) while processing attachment 78183 [details] on bug 51898.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.4
------- Comment #4 From 2011-01-07 04:17:59 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (Test shell crashed) while processing attachment 78123 [details] on bug 50921.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.4
------- Comment #5 From 2011-02-02 21:00:46 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 81001 [details] on bug 53640.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #6 From 2011-02-02 21:00:48 PST -------
Created an attachment (id=81028) [details]
Archive of layout-test-results from cr-jail-7
------- Comment #7 From 2011-02-04 16:26:17 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 81305 [details] on bug 52126.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #8 From 2011-02-04 16:26:20 PST -------
Created an attachment (id=81316) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #9 From 2011-02-04 16:36:09 PST -------
Sad.  I still need to fix the .zip uploading.  The zips should have crash reports in them now, thanks to aroben.
------- Comment #10 From 2011-02-15 21:04:04 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 82561 [details] on bug 54425.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #11 From 2011-02-15 21:04:07 PST -------
Created an attachment (id=82586) [details]
Archive of layout-test-results from cr-jail-3
------- Comment #12 From 2011-02-17 09:39:57 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 82816 [details] on bug 54641.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #13 From 2011-02-17 09:40:00 PST -------
Created an attachment (id=82822) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #14 From 2011-02-17 11:25:52 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 82815 [details] on bug 54666.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #15 From 2011-02-17 11:25:55 PST -------
Created an attachment (id=82834) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #16 From 2011-02-17 12:42:09 PST -------
Interesting.  The archive uploading is finally working, but the archive did not include the crash report file as I expect it would.
------- Comment #17 From 2011-02-17 12:46:14 PST -------
(In reply to comment #16)
> Interesting.  The archive uploading is finally working, but the archive did not include the crash report file as I expect it would.

What OS is the commit-queue running on? Maybe we're looking in the wrong location for crash logs?
------- Comment #18 From 2011-02-17 12:49:19 PST -------
All the commit-queues are running Snow Leopard 10.6.6.
------- Comment #19 From 2011-02-18 19:02:36 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 82859 [details] on bug 54605.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #20 From 2011-02-18 19:02:39 PST -------
Created an attachment (id=83049) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #21 From 2011-02-18 19:11:36 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 82883 [details] on bug 53978.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #22 From 2011-02-18 19:11:39 PST -------
Created an attachment (id=83050) [details]
Archive of layout-test-results from cr-jail-7
------- Comment #23 From 2011-02-22 22:52:38 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 83341 [details] on bug 31742.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #24 From 2011-02-22 22:52:41 PST -------
Created an attachment (id=83449) [details]
Archive of layout-test-results from cr-jail-7
------- Comment #25 From 2011-02-24 04:50:25 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 83041 [details] on bug 54787.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #26 From 2011-02-24 04:50:29 PST -------
Created an attachment (id=83635) [details]
Archive of layout-test-results from cr-jail-3
------- Comment #27 From 2011-02-24 07:20:02 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 83477 [details] on bug 55038.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #28 From 2011-02-24 07:20:05 PST -------
Created an attachment (id=83651) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #29 From 2011-02-24 09:19:12 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 83555 [details] on bug 55085.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #30 From 2011-02-24 09:19:15 PST -------
Created an attachment (id=83669) [details]
Archive of layout-test-results from cr-jail-3
------- Comment #31 From 2011-02-24 15:35:22 PST -------
run-webkit-tests --iterations 10000 media/invalid-media-url-crash.html easily reproduced the crash for me. :)

Thread 5 Crashed:
0   com.apple.MediaToolbox            0x00007fff880c5e1c fbfs_FigHTTPOpenCallback + 88
1   com.apple.MediaToolbox            0x00007fff88062177 FigCFHTTPThreadProcessMessage + 168
2   com.apple.CoreFoundation          0x00007fff821fc5e1 __CFMessagePortPerform + 497
3   com.apple.CoreFoundation          0x00007fff821966e1 __CFRunLoopRun + 5201
4   com.apple.CoreFoundation          0x00007fff82194dbf CFRunLoopRunSpecific + 575
5   com.apple.CoreFoundation          0x00007fff82194b46 CFRunLoopRun + 70
6   com.apple.CoreMedia               0x00007fff8342d55f FigThreadGlobalNetworkBufferingRunloop + 119
7   libSystem.B.dylib                 0x00007fff834b3536 _pthread_start + 331
8   libSystem.B.dylib                 0x00007fff834b33e9 thread_start + 13
------- Comment #32 From 2011-02-24 15:35:54 PST -------
Created an attachment (id=83732) [details]
crash report from local run
------- Comment #33 From 2011-02-24 15:36:29 PST -------
Reproducible crash = p1.  Assigning to Eric since he's Mr. Apple Media.
------- Comment #34 From 2011-02-25 11:02:53 PST -------
rdar://9054715
------- Comment #35 From 2011-02-28 16:58:53 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 84072 [details] on bug 55219.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #36 From 2011-02-28 16:58:56 PST -------
Created an attachment (id=84153) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #37 From 2011-03-01 05:05:37 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 84200 [details] on bug 55212.
Bot: cr-jail-3  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #38 From 2011-03-01 05:05:40 PST -------
Created an attachment (id=84215) [details]
Archive of layout-test-results from cr-jail-3
------- Comment #39 From 2011-03-03 10:17:48 PST -------
*** Bug 51304 has been marked as a duplicate of this bug. ***
------- Comment #40 From 2011-03-07 17:49:36 PST -------
The commit-queue just saw http/tests/media/video-load-twice.html flake (DumpRenderTree crashed) while processing attachment 84704 [details] on bug 55750.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #41 From 2011-03-07 17:49:39 PST -------
Created an attachment (id=85001) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #42 From 2011-03-23 10:57:40 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 86610 [details] on bug 56921.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #43 From 2011-03-23 10:57:43 PST -------
Created an attachment (id=86645) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #44 From 2011-03-23 12:36:30 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 86636 [details] on bug 56868.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #45 From 2011-03-23 12:36:34 PST -------
Created an attachment (id=86670) [details]
Archive of layout-test-results from cr-jail-7
------- Comment #46 From 2011-04-05 09:54:37 PST -------
The commit-queue just saw http/tests/media/video-load-twice.html flake (DumpRenderTree crashed) while processing attachment 88063 [details] on bug 57021.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #47 From 2011-04-05 09:54:39 PST -------
Created an attachment (id=88262) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #48 From 2011-04-05 19:36:42 PST -------
The commit-queue just saw media/invalid-media-url-crash.html flake (DumpRenderTree crashed) while processing attachment 88315 [details] on bug 57665.
Bot: cr-jail-8  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #49 From 2011-04-05 19:36:45 PST -------
Created an attachment (id=88352) [details]
Archive of layout-test-results from cr-jail-8
------- Comment #50 From 2011-04-05 19:51:03 PST -------
Seems we should just skip this test since we know it reproducibly crahes and there seems little point in running it as is.
------- Comment #51 From 2011-04-15 07:17:41 PST -------
Interesting that we've only ever seen this crash on the (I believe headless) mini's in the cr-jail.
------- Comment #52 From 2011-04-15 07:26:21 PST -------
Created an attachment (id=89785) [details]
Patch
------- Comment #53 From 2011-04-15 07:29:27 PST -------
*** Bug 57607 has been marked as a duplicate of this bug. ***
------- Comment #54 From 2011-04-15 07:31:00 PST -------
Created an attachment (id=89786) [details]
Patch for landing
------- Comment #55 From 2011-04-15 09:11:29 PST -------
(From update of attachment 89786 [details])
Clearing flags on attachment: 89786

Committed r83981: <http://trac.webkit.org/changeset/83981>
------- Comment #56 From 2011-04-15 09:11:39 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #57 From 2011-04-16 02:09:24 PST -------
The commit-queue just saw http/tests/media/video-load-twice.html flake (DumpRenderTree crashed) while processing attachment 89911 [details] on bug 58715.
Bot: cr-jail-4  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #58 From 2011-04-16 02:09:27 PST -------
Created an attachment (id=89922) [details]
Archive of layout-test-results from cr-jail-4
------- Comment #59 From 2011-04-18 21:26:03 PST -------
The commit-queue just saw http/tests/media/video-load-twice.html flake (DumpRenderTree crashed) while processing attachment 90098 [details] on bug 58346.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #60 From 2011-04-18 21:26:07 PST -------
Created an attachment (id=90140) [details]
Archive of layout-test-results from cr-jail-7
------- Comment #61 From 2011-04-19 20:32:55 PST -------
The commit-queue just saw http/tests/media/video-load-twice.html flake (DumpRenderTree crashed) while processing attachment 90271 [details] on bug 57678.
Bot: cr-jail-7  Port: Mac  Platform: Mac OS X 10.6.6
------- Comment #62 From 2011-04-19 20:32:58 PST -------
Created an attachment (id=90298) [details]
Archive of layout-test-results from cr-jail-7
------- Comment #63 From 2011-04-22 09:57:38 PST -------
Created an attachment (id=90715) [details]
Patch
------- Comment #64 From 2011-04-22 16:52:51 PST -------
The commit-queue encountered the following flaky tests while processing attachment 90715 [details]:

http/tests/xmlhttprequest/frame-load-cancelled-abort.html bug 58904 (authors: ap@webkit.org, beidson@apple.com, and hamaji@chromium.org)
The commit-queue is continuing to process your patch.
------- Comment #65 From 2011-04-22 16:54:33 PST -------
(From update of attachment 90715 [details])
Clearing flags on attachment: 90715

Committed r84707: <http://trac.webkit.org/changeset/84707>
------- Comment #66 From 2011-04-22 16:54:44 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #67 From 2011-04-24 06:24:03 PST -------
*** Bug 52117 has been marked as a duplicate of this bug. ***