Bug 24810 - Trying to get the Windows BuildBot into the Green
Summary: Trying to get the Windows BuildBot into the Green
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows Vista
: P2 Normal
Assignee: Brian Weinstein
URL: http://build.webkit.org/one_box_per_b...
Keywords:
: 24811 (view as bug list)
Depends on: 24822 24826 24827 24832 24833 24834 24835 24819 24820 24824 24825 24828 24829 24830 24831 95562
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 12:35 PDT by Brian Weinstein
Modified: 2012-08-31 05:39 PDT (History)
5 users (show)

See Also:


Attachments
Patch of Windows Skipped List (5.46 KB, patch)
2009-03-25 12:47 PDT, Brian Weinstein
no flags Details | Formatted Diff | Diff
Patch of Windows Skip List (5.49 KB, patch)
2009-03-25 12:58 PDT, Brian Weinstein
no flags Details | Formatted Diff | Diff
Windows Skip List r41995 (5.66 KB, patch)
2009-03-25 18:24 PDT, Brian Weinstein
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Weinstein 2009-03-25 12:35:42 PDT
The windows build bot hasn't been green in a while, so I am making the first push to get it back into the green.

I am starting the process by adding all the current failing tests in build.webkit.org (as of r41576) to the Windows skip list. I will be filing bugs for the failing tests individually, and this will also get the consistently failing ones out of the way to accurately identify regressions and see if removing these tests causes others to fail.
Comment 1 Brian Weinstein 2009-03-25 12:41:03 PDT
*** Bug 24811 has been marked as a duplicate of this bug. ***
Comment 2 Brian Weinstein 2009-03-25 12:47:38 PDT
Created attachment 28939 [details]
Patch of Windows Skipped List
Comment 3 Brian Weinstein 2009-03-25 12:58:42 PDT
Created attachment 28940 [details]
Patch of Windows Skip List

Fixed formatting, no tabs, and newline at the end of the Skip list
Comment 4 Brian Weinstein 2009-03-25 13:11:40 PDT
Once I have created individual bugs for all of the failed windows tests, I will upload a new version of the skipped list which ties in each new entry of the skip list to the bug that it belongs to

IE:

#http://bugs.webkit.org/show_bug?...   (bug report of css1... failure)
css1/text_properties/text_transform.html
Comment 5 Adam Roben (:aroben) 2009-03-25 14:15:21 PDT
Comment on attachment 28940 [details]
Patch of Windows Skip List

r=me as-is

I think some improvements could be made, though:

* There should be a space after the leading "#" on the comment lines, to match other lines in this file
* It would be good to put a comment at the end of this new section, too, so that people don't just add to the bottom of the file and mistakenly put the new failures in the r41975 section.
Comment 6 Brian Weinstein 2009-03-25 18:24:35 PDT
Created attachment 28959 [details]
Windows Skip List r41995

This patch updates the skip list to try and make bot green as of r41995, where some Windows libraries were changed.
Comment 7 Adam Roben (:aroben) 2009-03-26 07:57:11 PDT
Comment on attachment 28959 [details]
Windows Skip List r41995

r=me
Comment 8 Adam Roben (:aroben) 2009-03-26 08:06:55 PDT
Comment on attachment 28959 [details]
Windows Skip List r41995

Landed as r42004
Comment 9 Eric Seidel (no email) 2009-04-29 14:53:25 PDT
The bot seems rather green.  Why is this still open? http://build.webkit.org/waterfall
Comment 10 Eric Seidel (no email) 2009-04-29 14:53:50 PDT
Comment on attachment 28940 [details]
Patch of Windows Skip List

Clearing flag to remove this from the commit queue.
Comment 11 Brian Weinstein 2009-04-29 14:55:46 PDT
No reason it shouldn't still be open, I can close it now, however, now the issue is that there are probably some tests on the skip list that don't need to be there, should another bug be created for that?