Bug 135390 - [CSS Font Loading][meta] Implement CSS Font Loading
: [CSS Font Loading][meta] Implement CSS Font Loading
Status: RESOLVED DUPLICATE of bug 153346
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Myles C. Maxfield
http://dev.w3.org/csswg/css-font-load...
: InRadar, WebExposed
Depends on: 98395 112116 135340 135393 135420 135473 136044 136501 136502 136504 136505 137401 138755 158884
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-29 10:46 PDT by Bear Travis
Modified: 2016-06-20 14:32 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bear Travis 2014-07-29 10:46:57 PDT
Implement the CSS Font Loading specification. There is already an older implementation in place. The new work is to update it to the current spec and enable it.
Comment 1 John Daggett 2014-08-04 22:44:30 PDT
The spec has changed radically since the initial implementation work was done. Specifically, the Font Loading API is now Promise-based, so the update will be a non-trivial amount of work.

Latest spec:
http://dev.w3.org/csswg/css-font-loading/
Comment 2 Radar WebKit Bug Importer 2014-09-02 11:24:15 PDT
<rdar://problem/18202413>
Comment 3 Bram Stein 2015-12-18 07:53:23 PST
We (Adobe Typekit) are using this API quite heavily in our "kits" to detect font load events. If this API were supported by WebKit, we could avoid the expensive fallback strategy of polling a element for its width every N milliseconds.

It would be great if this feature received some attention.

For reference, I've described our use of the API in more detail here:

http://blog.typekit.com/2015/12/16/better-font-events-with-the-native-font-loading-api/
Comment 4 Myles C. Maxfield 2015-12-18 09:14:16 PST
Assigning to myself.
Comment 5 Myles C. Maxfield 2016-06-20 14:32:02 PDT

*** This bug has been marked as a duplicate of bug 153346 ***