Bug 135473 - [CSS Font Loading] Enable CSS Font Loading on Mac
Summary: [CSS Font Loading] Enable CSS Font Loading on Mac
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Bear Travis
URL:
Keywords:
Depends on:
Blocks: 135390
  Show dependency treegraph
 
Reported: 2014-07-31 14:34 PDT by Bear Travis
Modified: 2015-02-23 17:15 PST (History)
4 users (show)

See Also:


Attachments
Patch (8.67 KB, patch)
2014-07-31 15:25 PDT, Bear Travis
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-09 for mac-mountainlion-wk2 (893.96 KB, application/zip)
2014-07-31 17:27 PDT, Build Bot
no flags Details
Archive of layout-test-results from webkit-ews-15 for mac-mountainlion-wk2 (890.59 KB, application/zip)
2014-07-31 18:21 PDT, Build Bot
no flags Details
Archive of layout-test-results from webkit-ews-03 for mac-mountainlion (1.13 MB, application/zip)
2014-07-31 18:23 PDT, Build Bot
no flags Details
Updated Patch (8.82 KB, patch)
2014-09-03 14:33 PDT, Bear Travis
koivisto: review+
commit-queue: commit-queue-
Details | Formatted Diff | Diff
Updated patch (8.57 KB, patch)
2014-09-11 11:10 PDT, Bear Travis
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bear Travis 2014-07-31 14:34:04 PDT
Turn on CSS Font Loading on in the nightlies and enable the tests on the Mac Platform. Should subsequently enable across the other platforms.
Comment 1 Bear Travis 2014-07-31 15:25:53 PDT
Created attachment 235853 [details]
Patch
Comment 2 Build Bot 2014-07-31 17:27:49 PDT
Comment on attachment 235853 [details]
Patch

Attachment 235853 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/4503659933073408

New failing tests:
http/tests/loading/unfinished-main-resource-back-to-cached-page-callbacks.html
fast/history/timed-refresh-in-cached-frame.html
platform/mac-wk2/tiled-drawing/tiled-drawing-scroll-position-page-cache-restoration.html
media/restore-from-page-cache.html
http/tests/navigation/https-in-page-cache.html
animations/resume-after-page-cache.html
fast/forms/autocomplete-off-with-default-value-does-not-clear.html
compositing/iframes/page-cache-layer-tree.html
fast/overflow/horizontal-scroll-after-back.html
fast/events/pagehide-xhr-open.html
fast/dom/Window/timer-resume-on-navigation-back.html
loader/go-back-cached-main-resource.html
fast/events/suspend-timers.html
fast/images/animated-gif-restored-from-bfcache.html
http/tests/loading/unfinished-load-back-to-cached-page-callbacks.html
Comment 3 Build Bot 2014-07-31 17:27:51 PDT
Created attachment 235862 [details]
Archive of layout-test-results from webkit-ews-09 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-09  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 4 Build Bot 2014-07-31 18:21:37 PDT
Comment on attachment 235853 [details]
Patch

Attachment 235853 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/4657150253072384

New failing tests:
http/tests/loading/unfinished-main-resource-back-to-cached-page-callbacks.html
fast/history/timed-refresh-in-cached-frame.html
platform/mac-wk2/tiled-drawing/tiled-drawing-scroll-position-page-cache-restoration.html
media/restore-from-page-cache.html
http/tests/navigation/https-in-page-cache.html
animations/resume-after-page-cache.html
fast/forms/autocomplete-off-with-default-value-does-not-clear.html
compositing/iframes/page-cache-layer-tree.html
fast/overflow/horizontal-scroll-after-back.html
fast/events/pagehide-xhr-open.html
fast/dom/Window/timer-resume-on-navigation-back.html
loader/go-back-cached-main-resource.html
fast/events/suspend-timers.html
fast/images/animated-gif-restored-from-bfcache.html
http/tests/loading/unfinished-load-back-to-cached-page-callbacks.html
Comment 5 Build Bot 2014-07-31 18:21:39 PDT
Created attachment 235866 [details]
Archive of layout-test-results from webkit-ews-15 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-15  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 6 Build Bot 2014-07-31 18:23:43 PDT
Comment on attachment 235853 [details]
Patch

Attachment 235853 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6473003370020864

New failing tests:
fast/harness/use-page-cache.html
media/restore-from-page-cache.html
http/tests/navigation/https-in-page-cache.html
fast/images/animated-gif-restored-from-bfcache.html
http/tests/loading/unfinished-load-back-to-cached-page-callbacks.html
fast/history/timed-refresh-in-cached-frame.html
plugins/crash-restoring-plugin-page-from-page-cache.html
platform/mac/editing/input/unconfirmed-text-navigation-with-page-cache.html
fast/forms/autocomplete-off-with-default-value-does-not-clear.html
compositing/iframes/page-cache-layer-tree.html
fast/events/pageshow-pagehide-on-back-cached.html
fast/harness/page-cache-crash-on-data-urls.html
fast/loader/window-properties-restored-from-page-cache.html
fast/events/pageshow-pagehide-on-back-cached-with-frames.html
animations/resume-after-page-cache.html
fast/overflow/horizontal-scroll-after-back.html
fast/events/pagehide-xhr-open.html
fast/dom/Window/timer-resume-on-navigation-back.html
loader/go-back-cached-main-resource.html
http/tests/loading/unfinished-main-resource-back-to-cached-page-callbacks.html
plugins/netscape-plugin-page-cache-works.html
platform/mac/fast/scrolling/scroll-select-bottom-test.html
fast/events/pagehide-timeout.html
fast/events/suspend-timers.html
Comment 7 Build Bot 2014-07-31 18:23:45 PDT
Created attachment 235867 [details]
Archive of layout-test-results from webkit-ews-03 for mac-mountainlion

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: webkit-ews-03  Port: mac-mountainlion  Platform: Mac OS X 10.8.5
Comment 8 Bear Travis 2014-09-03 14:33:11 PDT
Created attachment 237583 [details]
Updated Patch

Fixed bug 136044, which originally caused the test failures. Re-uploading to see what happens.
Comment 9 WebKit Commit Bot 2014-09-11 10:39:45 PDT
Comment on attachment 237583 [details]
Updated Patch

Rejecting attachment 237583 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.appspot.com', '--bot-id=webkit-cq-02', 'apply-attachment', '--no-update', '--non-interactive', 237583, '--port=mac']" exit_code: 2 cwd: /Volumes/Data/EWS/WebKit

Last 500 characters of output:
unk FAILED -- saving rejects to file Source/WebKit2/Configurations/FeatureDefines.xcconfig.rej
patching file LayoutTests/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file LayoutTests/platform/mac/TestExpectations
Hunk #1 FAILED at 1401.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/mac/TestExpectations.rej

Failed to run "[u'/Volumes/Data/EWS/WebKit/Tools/Scripts/svn-apply', '--force', '--reviewer', u'Antti Koivisto']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Full output: http://webkit-queues.appspot.com/results/6002615666081792
Comment 10 Bear Travis 2014-09-11 11:10:47 PDT
Created attachment 237968 [details]
Updated patch

Merging with trunk to fix up conflicts.
Comment 11 WebKit Commit Bot 2014-09-11 12:37:37 PDT
Comment on attachment 237968 [details]
Updated patch

Clearing flags on attachment: 237968

Committed r173531: <http://trac.webkit.org/changeset/173531>
Comment 12 WebKit Commit Bot 2014-09-11 12:37:41 PDT
All reviewed patches have been landed.  Closing bug.
Comment 13 Ryosuke Niwa 2015-02-23 17:15:04 PST
It looks like this API has been changed in the latest spec. See bugs 141937 and 141938.