Bug 121859 - [mac] Stop using DrawingAreaImpl on PLATFORM(MAC)
Summary: [mac] Stop using DrawingAreaImpl on PLATFORM(MAC)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tim Horton
URL:
Keywords: InRadar
: 122006 122007 (view as bug list)
Depends on: 121874 122006 122007 122172
Blocks: 121856
  Show dependency treegraph
 
Reported: 2013-09-24 13:20 PDT by Tim Horton
Modified: 2013-10-02 14:17 PDT (History)
11 users (show)

See Also:


Attachments
preliminary (124.77 KB, patch)
2013-10-01 18:31 PDT, Tim Horton
eflews.bot: commit-queue-
Details | Formatted Diff | Diff
patch (133.45 KB, patch)
2013-10-02 13:51 PDT, Tim Horton
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Horton 2013-09-24 13:20:42 PDT
We should be using TiledCoreAnimationDrawingArea everywhere, including for tests. It should be the only drawing area you can acquire when making a WKView, and should happen automatically.

This would be relatively straightforward, except for two things:

* TCADA currently explicitly forces use of threaded scrolling, which breaks a number of tests. These two things aren't necessarily related and should be decoupled.

* Using tiled drawing means the layer tree dumps will be slightly different for some tests, so we need to adjust layer tree output to be consistent (otherwise Mac-WK2 will be different from Mac-WK1 and all the other ports).
Comment 1 Radar WebKit Bug Importer 2013-09-24 13:21:12 PDT
<rdar://problem/15069359>
Comment 2 Tim Horton 2013-10-01 18:31:09 PDT
Created attachment 213141 [details]
preliminary
Comment 3 Tim Horton 2013-10-01 18:41:06 PDT
*** Bug 122006 has been marked as a duplicate of this bug. ***
Comment 4 Tim Horton 2013-10-01 18:41:39 PDT
*** Bug 122007 has been marked as a duplicate of this bug. ***
Comment 5 EFL EWS Bot 2013-10-01 19:10:54 PDT
Comment on attachment 213141 [details]
preliminary

Attachment 213141 [details] did not pass efl-wk2-ews (efl-wk2):
Output: http://webkit-queues.appspot.com/results/2905264
Comment 6 Tim Horton 2013-10-02 10:15:51 PDT
(In reply to comment #5)
> (From update of attachment 213141 [details])
> Attachment 213141 [details] did not pass efl-wk2-ews (efl-wk2):
> Output: http://webkit-queues.appspot.com/results/2905264

>c++: internal compiler error: Killed (program cc1plus)
>Please submit a full bug report, with preprocessed source if appropriate.
> See <file:///usr/share/doc/gcc-4.7/README.Bugs> for instructions.
> make[2]: *** [Source/WebCore/CMakeFiles/WebCore.dir/html/canvas/WebGLRenderingContext.cpp.o] Error 4

Sounds like something that I didn't cause.
Comment 7 Tim Horton 2013-10-02 13:51:25 PDT
Created attachment 213195 [details]
patch
Comment 8 Tim Horton 2013-10-02 14:00:17 PDT
I filed a bunch of bugs about test regressions:

https://bugs.webkit.org/show_bug.cgi?id=122233 - A variety of regions tests have overflow which is not accounted for, and fail
https://bugs.webkit.org/show_bug.cgi?id=122234 - A bunch of tests fail with minor color mismatches (I'm going to look at this one next, along with some other things)
https://bugs.webkit.org/show_bug.cgi?id=122235 - Some css3/ tests fail with fringing around tiled background-images that intersect tile boundaries
https://bugs.webkit.org/show_bug.cgi?id=122237 - fast/table/crash-section-logical-height-changed-needsCellRecalc.html asserts
https://bugs.webkit.org/show_bug.cgi?id=122238 - fast/layers/no-clipping-overflow-hidden-added-after-transform.html fails with tiled drawing
Comment 9 Tim Horton 2013-10-02 14:17:21 PDT
http://trac.webkit.org/changeset/156793