Bug 231828 - Enable accelerated drawing in the iOS simulator
Summary: Enable accelerated drawing in the iOS simulator
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 219375 (view as bug list)
Depends on: 235462 235671 235685
Blocks: 233914
  Show dependency treegraph
 
Reported: 2021-10-15 13:41 PDT by Simon Fraser (smfr)
Modified: 2022-03-14 16:34 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.49 KB, patch)
2021-10-15 13:41 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (2.36 KB, patch)
2021-10-19 15:19 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch for EWS (2.35 KB, patch)
2022-01-12 13:00 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (3.12 KB, patch)
2022-02-07 20:28 PST, Jon Lee
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (3.06 KB, patch)
2022-02-09 08:20 PST, Jon Lee
no flags Details | Formatted Diff | Diff
Patch (3.02 KB, patch)
2022-02-09 16:00 PST, Jon Lee
no flags Details | Formatted Diff | Diff
Patch (3.15 KB, patch)
2022-02-10 09:48 PST, Jon Lee
no flags Details | Formatted Diff | Diff
Patch (3.03 KB, patch)
2022-02-11 09:58 PST, Jon Lee
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2021-10-15 13:41:19 PDT
Enable accelerated drawing in the iOS simulator
Comment 1 Simon Fraser (smfr) 2021-10-15 13:41:54 PDT
Created attachment 441419 [details]
Patch
Comment 2 Radar WebKit Bug Importer 2021-10-15 13:53:32 PDT
<rdar://problem/84315491>
Comment 3 Myles C. Maxfield 2021-10-15 14:09:13 PDT
Comment on attachment 441419 [details]
Patch

r=mews
Comment 4 Simon Fraser (smfr) 2021-10-19 15:19:57 PDT
Created attachment 441809 [details]
Patch
Comment 5 Simon Fraser (smfr) 2022-01-12 13:00:52 PST
Created attachment 448987 [details]
Patch for EWS
Comment 6 Jon Lee 2022-02-07 20:28:03 PST
Created attachment 451199 [details]
Patch
Comment 7 Jon Lee 2022-02-08 11:17:42 PST
Additional Gardening:
https://commits.webkit.org/r289253
https://commits.webkit.org/r289402
Comment 8 Jon Lee 2022-02-09 08:20:23 PST
Created attachment 451381 [details]
Patch
Comment 9 Jon Lee 2022-02-09 16:00:42 PST
Created attachment 451456 [details]
Patch
Comment 10 Jon Lee 2022-02-10 09:48:45 PST
Created attachment 451555 [details]
Patch
Comment 11 Jon Lee 2022-02-11 09:58:56 PST
Created attachment 451717 [details]
Patch
Comment 12 Jon Lee 2022-02-12 20:02:45 PST
rdar://70104139
Comment 13 Jon Lee 2022-02-14 15:00:03 PST
Committed r289770 (247242@trunk): <https://commits.webkit.org/247242@trunk>
Comment 14 Jon Lee 2022-02-14 15:01:23 PST
*** Bug 219375 has been marked as a duplicate of this bug. ***