Bug 21835 - Overdraw at box corners when using RGBA colors with alpha
: Overdraw at box corners when using RGBA colors with alpha
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Simon Fraser (smfr)
http://www.hellerich.net/files/2008/w...
: HasReduction, InRadar
Depends on: 58761
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 12:29 PDT by Dan H
Modified: 2011-05-08 20:47 PDT (History)
13 users (show)

See Also:


Attachments
Test case that makes the problem more obvious (270 bytes, text/html)
2010-01-26 21:54 PST, Alex Taylor
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan H 2008-10-23 12:29:12 PDT
View URL for demonstration.  When top, right, bottom & left borders of an element have different colors, at each corner, they cut along the 45 degree angle and bevel next to each other.

When using RGBa color values, which is going to be available in CSS3, like-colored edges "overlap" on corners instead of bevel.
Comment 1 Simon Fraser (smfr) 2008-12-09 10:19:30 PST
<rdar://problem/5843531>
Comment 2 Mark Rowe (bdash) 2009-01-29 18:24:45 PST
*** Bug 23632 has been marked as a duplicate of this bug. ***
Comment 3 nemo 2010-01-22 16:33:27 PST
I suppose the odd behaviour I ran into here:
http://m8y.org/tmp/testcase177.xhtml

(most noticeable in the enlarged bottom border)

is the same?
Comment 4 Simon Fraser (smfr) 2010-01-22 16:43:24 PST
Yep, that looks like the rgba() issue.
Comment 5 nemo 2010-01-26 10:16:21 PST
Simplified testcase:

data:text/html,<div style="width:0;border:16px solid rgba(0,0,0,0.3);-webkit-border-radius:5px"></div>
Comment 6 nemo 2010-01-26 11:03:44 PST
Oh, and is this really a minor?
I mean, right now the only impact is my borders look a rather ugly in Safari and Chrome, but still, they *do* look ugly.

I guess I'm just moderately concerned since it looks like this was filed a year and a half ago.  Another year and a half of ugly borders in 10% or so of the browsers out there would be a little unfortunate.

And, yes, they look plain in IE, I know.  But boss is fine with that, and at least they don't have weird patterns in 'em.
Comment 7 Simon Fraser (smfr) 2010-01-26 11:08:24 PST
*** Bug 31776 has been marked as a duplicate of this bug. ***
Comment 8 Simon Fraser (smfr) 2010-01-26 11:09:45 PST
See also bug 9197, bug 19651.
We're aware of this. It's more than minor.
Comment 9 Alex Taylor 2010-01-26 21:54:38 PST
Created attachment 47492 [details]
Test case that makes the problem more obvious

I'll add some notes in here in case someone takes this bug before I find time to do so (won't be for a few months probably).

I imagine this bug will be fixed when #9197 and #19651 are resolved but I'll leave it open for now as it makes the other two occur more often and in a more likely case.
Comment 10 Simon Fraser (smfr) 2011-02-25 08:36:58 PST
*** Bug 36103 has been marked as a duplicate of this bug. ***
Comment 11 Simon Fraser (smfr) 2011-02-25 08:37:03 PST
*** Bug 39591 has been marked as a duplicate of this bug. ***
Comment 12 Simon Fraser (smfr) 2011-04-19 11:46:30 PDT
http://trac.webkit.org/changeset/84273
Comment 13 Daniel Bates 2011-05-08 20:47:11 PDT
*** Bug 60363 has been marked as a duplicate of this bug. ***