Bug 39591 - rgba semi-transparent borders overlap (are drawn twice) in the corners
Summary: rgba semi-transparent borders overlap (are drawn twice) in the corners
Status: RESOLVED DUPLICATE of bug 21835
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-24 03:42 PDT by Richard
Modified: 2011-05-06 16:29 PDT (History)
5 users (show)

See Also:


Attachments
Test case (83 bytes, text/html)
2010-05-24 03:42 PDT, Richard
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard 2010-05-24 03:42:34 PDT
Created attachment 56868 [details]
Test case

When I request a border around a box like this:

<div style="border:40px solid rgba(0,128,0,.5)">X</div>

then the semi-transparent border is drawn twice over each corner of the box. In other words, the vertical and horizontal parts of the border overlap in the corner.

Tested with WebKit-r60027. There are some similar bugs, e.g. #21835, but they all seem to involve border radius or similar advanced border CSS, so I created a new bug instead.
Comment 1 Matthew Mirande 2010-12-13 10:50:34 PST
FWIW, I'm seeing this in 533.19.4
Comment 2 Simon Fraser (smfr) 2011-02-25 08:37:03 PST

*** This bug has been marked as a duplicate of bug 21835 ***
Comment 3 Ben Wells 2011-05-06 16:29:39 PDT
*** Bug 60364 has been marked as a duplicate of this bug. ***