Bug 31776 - using rgba for the color of a rounded border looks odd
Summary: using rgba for the color of a rounded border looks odd
Status: RESOLVED DUPLICATE of bug 21835
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Minor
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2009-11-21 16:33 PST by Joel
Modified: 2010-01-26 11:08 PST (History)
3 users (show)

See Also:


Attachments
thumbnails with borders, second bordered image has color set w/RGBA (30.82 KB, image/png)
2009-11-21 16:33 PST, Joel
no flags Details
Test Case showing border overlap (270 bytes, text/html)
2010-01-23 18:41 PST, Alex Taylor
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel 2009-11-21 16:33:18 PST
Created attachment 43663 [details]
thumbnails with borders, second bordered image has color set w/RGBA

It seems like there's an overlap or something for the radius'd borders.  See attached image.   the thumbnail on the right has this css applied to it:

.category-work #thumbnails li { display:block; float:left; border:solid 15px rgba(0,164,201,.3); margin-right:10px; -moz-border-radius:3px; -webkit-border-radius:3px;}
Comment 1 Alex Taylor 2010-01-23 18:41:16 PST
Created attachment 47285 [details]
Test Case showing border overlap

This bug only occurs when the border-radius is less than the border-width.
Comment 2 Simon Fraser (smfr) 2010-01-26 11:08:24 PST

*** This bug has been marked as a duplicate of bug 21835 ***