Bug 36103 - Using RGBa for border when box background is a gradient gives uneven coloring
Summary: Using RGBa for border when box background is a gradient gives uneven coloring
Status: RESOLVED DUPLICATE of bug 21835
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://oli-studio.com/bugs/browser/rg...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-14 20:27 PDT by Oli Studholme
Modified: 2011-02-25 08:36 PST (History)
2 users (show)

See Also:


Attachments
test case (849 bytes, text/html)
2010-03-15 00:55 PDT, Philippe Wittenbergh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oli Studholme 2010-03-14 20:27:10 PDT
an alpha-transparent border should be applied uniformly even when the object’s background is a gradient. In Webkit the top and bottom borders are alpha-transparency of the parent object, but the left and right borders are alpha-transparency of the object’s gradient background.
Comment 1 Oli Studholme 2010-03-14 20:28:37 PDT
It seems there are a bunch of border issues, with this bug being an overview of many of them:
https://bugs.webkit.org/show_bug.cgi?id=21835
Comment 2 Philippe Wittenbergh 2010-03-15 00:35:04 PDT
Fx 3.6/ Gecko 1.9.2 is fairly buggy in this, still (in short, rendering of the linked testcase is incorrect as well - the gradient should repeat into the border edge and affect the color of the border). That is fixed on Gecko trunk.
See https://bugzilla.mozilla.org/show_bug.cgi?id=538909
Comment 3 Philippe Wittenbergh 2010-03-15 00:55:41 PDT
Created attachment 50689 [details]
test case

Note also that the linked test case doesn't apply the same gradient for Gecko and WebKit (the WebKit gradient has repeat-x, the Gecko one has 'repeat' - the default).
Attached testcase corrects this (and the rendering is identical in Gecko 1.9.3a latest nightly and WebKit latest nightly, with the exception of the corners.
Comment 4 Oli Studholme 2010-03-15 04:28:16 PDT
Thanks for adding the extra information Philippe, and for uploading a corrected test case. I’ve also added repeat-x to my test case
Comment 5 Simon Fraser (smfr) 2011-02-25 08:36:58 PST

*** This bug has been marked as a duplicate of bug 21835 ***