Bug 21274 - Add-Link in Wordpress Editor blocks window
Summary: Add-Link in Wordpress Editor blocks window
Status: RESOLVED DUPLICATE of bug 21382
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL: http://wordpress.com
Keywords:
: 22100 22121 22124 (view as bug list)
Depends on:
Blocks: 13744
  Show dependency treegraph
 
Reported: 2008-10-01 08:29 PDT by Kay Hidde
Modified: 2008-12-27 15:58 PST (History)
6 users (show)

See Also:


Attachments
Screenshot (composed as is vs. expected) (203.22 KB, image/png)
2008-10-01 08:49 PDT, Kay Hidde
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kay Hidde 2008-10-01 08:29:47 PDT
Wordpress (the common blog system; here version 2.6.x) contains a web based editor wich allows an almost complete graphical user interface for manipulating web content. There is a function for adding a link (anchor with reference to URL) to a text. Therefore a dialog is drawn which contains edit fields, menus, buttons and can be moved across the browsers window. 

In all officially released browsers this function works fine but in the nightly builds of Webkit the browser window is greyed completely and neither the drawn dialog nor the window behind is accessible by clicking or via keyboard (the dialog should close on ESC).

I regret, but I am not a programmer so my bug report is very detailed and is not stripped down to a certain Javascript routine. Nevertheless, the bug is reproducible in Webkit Nightly Build on Mac and Windows. In case you need more details, please let me know.
Comment 1 Kay Hidde 2008-10-01 08:49:14 PDT
Created attachment 23981 [details]
Screenshot (composed as is vs. expected)
Comment 2 Stephen Suess 2008-10-29 16:11:51 PDT
Same exact problem here. Have noticed it in at least the last few builds. (Webkit Version 3.1.2 (5525.20.1), OSX 10.5.5)
Comment 3 Haoyang Xu 2008-11-17 05:17:31 PST
Same problem here, using build 38386 and a few previous builds.
Comment 4 Robert Blaut 2008-12-27 12:33:07 PST
*** Bug 22121 has been marked as a duplicate of this bug. ***
Comment 5 Robert Blaut 2008-12-27 12:34:59 PST
*** Bug 22124 has been marked as a duplicate of this bug. ***
Comment 6 Robert Blaut 2008-12-27 13:04:34 PST
I can confirm this bug. It's replicable on wordpress.com (Wordpress 2.7 installed).
Comment 7 Robert Blaut 2008-12-27 13:13:39 PST
*** Bug 22100 has been marked as a duplicate of this bug. ***
Comment 8 Robert Blaut 2008-12-27 15:58:22 PST
This bug is example of general bug regarding supporting TinyMCE rich text editor in WebKit. I close this bug as duplication of bug 21382.

*** This bug has been marked as a duplicate of 21382 ***