Bug 13744 - WordPress Editor: Master Bug
Summary: WordPress Editor: Master Bug
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 523.x (Safari 3)
Hardware: All OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on: 13743 13746 14350 21274
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 17:30 PDT by Justin Garcia
Modified: 2010-06-08 17:18 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Garcia 2007-05-15 17:30:17 PDT
http://wordpress.com/
Login with thabih/79f5587
Click on New Post in the top left

<rdar://problem/5191694> WordPress Editor: Master Bug
Comment 1 Robert Blaut 2008-07-16 05:38:06 PDT
All blocking bugs are already fixed. I think the meta bug should be fixed, isn't it?
Comment 2 Justin Garcia 2008-07-16 10:51:43 PDT
There is https://bugs.webkit.org/show_bug.cgi?id=17993 but it's not exactly blocking this bug anymore since it doesn't happen with current versions of WordPress (post 2.5).  We are tracking some WordPress editor bugs internally.  I'm going to check and see if any of those are still reproducible...
Comment 3 Jeremy G. Pippin 2009-03-27 18:35:32 PDT
REGRESSION:  In TinyMCE (observed environment: Wordpress 2.7.1 post edit with visual editor turned ON), using various javascript-driven "pop ups" generates odd behavior; namely, the window only partially rendering (just the header and footer).

This behavior is exhibited in r41944, but was NOT exhibited in r41894.

REPRO: Create a new post in a Wordpress installation (in Visual, not HTML mode), highlight some text and attempt to use the link button to assign a link to this test. Presumably, any instance of TinyMCE should be able to reproduce this bug, since Wordpress pretty directly implements TinyMCE.
Comment 4 Digital Soup 2010-06-08 14:18:55 PDT
WordPress version 2.9.2 Visual Editor content is not visible in Webkit Nightly build version r60820. WordPress HTML editor is not affected.
Comment 5 Alexey Proskuryakov 2010-06-08 17:18:05 PDT
That's probably bug 40292, which will be fixed in the next nightly.

I don't think that this bug is helpful any more - all dependencies have been resolved, so all it does is confuse people into reporting new issues here, where they can easily be overlooked.

Re comment 3 - please file a new bug about that, if it still happens. Sorry for overlooking your report, it's been in an old bug, so I didn't see it.