Bug 160880

Summary: Update WebCrypto implementation to match the latest spec
Product: WebKit Reporter: Jiewen Tan <jiewen_tan>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: barrett.harber+webkit, bfulgham, jiewen_tan, rob, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=122679
https://bugs.webkit.org/show_bug.cgi?id=164938
https://bugs.webkit.org/show_bug.cgi?id=166746
Bug Depends on: 104851, 159638, 160067, 160877, 160883, 160894, 164868, 164982, 165124, 165540, 165554, 165557    
Bug Blocks: 143458, 151125, 157175, 165723    

Description Jiewen Tan 2016-08-15 16:53:45 PDT
Update WebCrypto implementation to match the latest spec:
https://www.w3.org/TR/WebCryptoAPI/
Comment 1 Jiewen Tan 2016-08-15 16:54:16 PDT
<rdar://problem/17075396>
Comment 2 Jiewen Tan 2016-08-15 16:55:46 PDT
This is the umbrella bug to keep track of the progress being made.
Comment 3 Alexey Proskuryakov 2016-10-12 23:27:15 PDT
*** Bug 163355 has been marked as a duplicate of this bug. ***
Comment 4 Barrett Harber 2016-10-15 14:40:35 PDT
+1
Comment 5 Jiewen Tan 2016-12-12 17:35:01 PST
Close this this bug as this feature is completed.