Bug 93353 - [Meta][EFL][WK2] EFL WK2 bot is red
Summary: [Meta][EFL][WK2] EFL WK2 bot is red
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Gyuyoung Kim
URL:
Keywords:
Depends on: 92726 92749 93470 141959 89072 93454 93645 93796 124664 125573 141462 141591 141592 141593 141594 141627 141628 141630 141631 141891 141892 141894 141895 141896 141897 141958 142157 142158 142426 142427 142450 142451 142452 142481 142483 142561 142570 142571 142653 142763 142764 142766 143415 143416 143626 143877 143878 144004 144005 144006 146139 146887 149201 149202
Blocks: 61838
  Show dependency treegraph
 
Reported: 2012-08-07 04:49 PDT by Mikhail Pozdnyakov
Modified: 2017-03-11 10:34 PST (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Pozdnyakov 2012-08-07 04:49:01 PDT
This is the meta bug for making EFL WK2 bot green.
Currently we have following test cases not passing on EFL WK2.

Regressions: Unexpected text diff mismatch : (132)
  editing/execCommand/format-block-multiple-paragraphs-in-pre.html = TEXT
  editing/input/emacs-ctrl-o.html = TEXT
  editing/input/page-up-down-scrolls.html = TEXT
  fast/block/float/float-in-float-hit-testing.html = TEXT
  fast/cookies/local-file-can-set-cookies.html = TEXT
  fast/css/bidi-override-in-anonymous-block.html = TEXT
  fast/css/media-rule-screenDepthPerComponent.html = TEXT
  fast/css/relative-positioned-block-crash.html = TEXT
  fast/dom/HTMLLinkElement/link-and-subresource-test-nonexistent.html = TEXT
  fast/dom/HTMLLinkElement/link-and-subresource-test.html = TEXT
  fast/dom/HTMLLinkElement/prefetch.html = TEXT
  fast/dom/HTMLProgressElement/indeterminate-progress-001.html = TEXT
  fast/dom/HTMLProgressElement/progress-bar-value-pseudo-element.html = TEXT
  fast/dom/HTMLProgressElement/progress-writing-mode.html = TEXT
  fast/dom/Window/mozilla-focus-blur.html = TEXT
  fast/dom/Window/timer-resume-on-navigation-back.html = TEXT
  fast/dom/frame-loading-via-document-write.html = TEXT
  fast/dom/navigation-type-back-forward.html = TEXT
  fast/dom/navigation-type-navigate.html = TEXT
  fast/dom/navigation-type-reload.html = TEXT
  fast/dom/title-directionality-removeChild.html = TEXT
  fast/dom/title-directionality.html = TEXT
  fast/events/node-event-anchor-lock.html = TEXT
  fast/events/pagehide-timeout.html = TEXT
  fast/events/pagehide-xhr-open.html = TEXT
  fast/events/pageshow-pagehide-on-back-cached-with-frames.html = TEXT
  fast/events/pageshow-pagehide-on-back-cached.html = TEXT
  fast/events/popup-blocking-click-in-iframe.html = TEXT
  fast/events/scroll-after-click-on-tab-index.html = TEXT
  fast/events/suspend-timers.html = TEXT
  fast/events/touch/basic-multi-touch-events-limited.html = TEXT
  fast/events/touch/basic-multi-touch-events.html = TEXT
  fast/events/touch/basic-single-touch-events.html = TEXT
  fast/events/touch/multi-touch-grouped-targets.html = TEXT
  fast/events/touch/send-oncancel-event.html = TEXT
  fast/events/touch/tap-highlight-color.html = TEXT
  fast/events/touch/touch-active-state.html = TEXT
  fast/events/touch/touch-before-pressing-spin-button.html = TEXT
  fast/events/touch/touch-coords-in-zoom-and-scroll.html = TEXT
  fast/events/touch/touch-inside-iframe.html = TEXT
  fast/events/touch/touch-slider-no-js-touch-listener.html = TEXT
  fast/events/touch/touch-slider.html = TEXT
  fast/events/touch/touch-stale-node-crash.html = TEXT
  fast/events/touch/touch-target-limited.html = TEXT
  fast/events/touch/touch-target.html = TEXT
  fast/forms/legend-access-key.html = TEXT
  fast/forms/listbox-deselect-scroll.html = TEXT
  fast/forms/listbox-selection.html = TEXT
  fast/forms/plaintext-mode-1.html = TEXT
  fast/forms/select-multiple-elements-with-mouse-drag-with-options-less-than-size.html = TEXT
  fast/forms/select-writing-direction-natural.html = TEXT
  fast/forms/validation-message-in-relative-body.html = TEXT
  fast/forms/validation-message-user-modify.html = TEXT
  fast/frames/flattening/iframe-tiny.html = TEXT
  fast/harness/use-page-cache.html = TEXT
  fast/history/timed-refresh-in-cached-frame.html = TEXT
  fast/loader/submit-form-while-parsing-2.html = TEXT
  fast/media/color-does-not-include-alpha.html = TEXT
  fast/media/implicit-media-all.html = TEXT
  fast/media/media-query-list-02.html = TEXT
  fast/media/media-query-list-03.html = TEXT
  fast/media/media-query-list-04.html = TEXT
  fast/media/media-query-list-05.html = TEXT
  fast/media/media-query-list-06.html = TEXT
  fast/media/media-query-list-07.html = TEXT
  fast/media/mq-compound-query-01.html = TEXT
  fast/media/mq-compound-query-02.html = TEXT
  fast/media/mq-compound-query-03.html = TEXT
  fast/media/mq-compound-query-04.html = TEXT
  fast/media/mq-js-media-except-01.html = TEXT
  fast/media/mq-js-stylesheet-media-01.html = TEXT
  fast/media/mq-js-stylesheet-media-02.html = TEXT
  fast/media/mq-js-stylesheet-media-03.html = TEXT
  fast/media/mq-simple-query-05.html = TEXT
  fast/media/mq-valueless.html = TEXT
  fast/media/view-mode-media-feature.html = TEXT
  fast/mutation/end-of-task-delivery.html = TEXT
  fast/repaint/fixed-move-after-keyboard-scroll.html = TEXT
  fast/replaced/no-focus-ring-embed.html = TEXT
  fast/replaced/no-focus-ring-object.html = TEXT
  fast/ruby/nested-ruby.html = TEXT
  fast/ruby/ruby-beforeafter.html = TEXT
  fast/ruby/ruby-empty-rt.html = TEXT
  fast/ruby/ruby-length.html = TEXT
  fast/ruby/ruby-run-break.html = TEXT
  fast/ruby/ruby-runs-spans.html = TEXT
  fast/ruby/ruby-runs.html = TEXT
  fast/ruby/ruby-simple-rp.html = TEXT
  fast/ruby/ruby-simple.html = TEXT
  fast/ruby/ruby-trailing.html = TEXT
  fast/ruby/rubyDOM-insert-rt.html = TEXT
  fast/ruby/rubyDOM-insert-text1.html = TEXT
  fast/ruby/rubyDOM-insert-text2.html = TEXT
  fast/ruby/rubyDOM-insert-text3.html = TEXT
  fast/ruby/rubyDOM-remove-rt1.html = TEXT
  fast/ruby/rubyDOM-remove-rt2.html = TEXT
  fast/ruby/rubyDOM-remove-text1.html = TEXT
  fast/ruby/rubyDOM-remove-text2.html = TEXT
  fast/text/international/spaces-combined-in-vertical-text.html = TEXT
  fast/viewport/viewport-128.html = TEXT
  fast/workers/worker-cloneport.html = TEXT
  http/tests/appcache/load-from-appcache-defer-resume-crash.html = TEXT
  http/tests/inspector/network/network-sidebar-width.html = TEXT
  http/tests/inspector/resource-main-cookies.php = TEXT
  http/tests/misc/object-embedding-svg-delayed-size-negotiation-2.htm = TEXT
  http/tests/misc/prefetch-purpose.html = TEXT
  http/tests/navigation/https-in-page-cache.html = TEXT
  http/tests/security/aboutBlank/security-context-grandchildren-lexical.html = TEXT
  http/tests/security/aboutBlank/security-context-grandchildren-write-lexical.html = TEXT
  http/tests/security/aboutBlank/security-context-grandchildren-writeln-lexical.html = TEXT
  http/tests/security/aboutBlank/security-context-grandchildren.html = TEXT
  http/tests/security/aboutBlank/security-context-window-open.html = TEXT
  http/tests/security/aboutBlank/security-context-with-base-tag.html = TEXT
  http/tests/security/aboutBlank/security-context-write.html = TEXT
  http/tests/security/aboutBlank/security-context-writeln.html = TEXT
  http/tests/security/aboutBlank/security-context.html = TEXT
  http/tests/security/cookies/assign-document-url.html = TEXT
  http/tests/security/cookies/base-about-blank.html = TEXT
  http/tests/security/cookies/base-tag.html = TEXT
  http/tests/security/cookies/basic.html = TEXT
  http/tests/security/cookies/document-open.html = TEXT
  http/tests/xmlhttprequest/workers/abort-exception-assert.html = TEXT
  inspector/debugger/debugger-completions-on-call-frame.html = TEXT
  inspector/extensions/extensions-panel.html = TEXT
  jquery/attributes.html = TEXT
  storage/domstorage/storage-close-database-on-idle.html = TEXT
  svg/dom/viewspec-parser-1.html = TEXT
  svg/dom/viewspec-parser-2.html = TEXT
  svg/dom/viewspec-parser-3.html = TEXT
  svg/dom/viewspec-parser-4.html = TEXT
  svg/dom/viewspec-parser-5.html = TEXT
  webintents/web-intents-invoke-port.html = TEXT

Regressions: Unexpected crashes : (15)
  fast/dom/register-protocol-handler.html = CRASH
  fast/dom/unregister-protocol-handler.html = CRASH
  fast/forms/select/menulist-popup-crash.html = CRASH
  fast/loader/document-with-fragment-url-1.html = CRASH
  fast/overflow/lots-of-sibling-inline-boxes.html = CRASH
  http/tests/loading/fire-error-event-script-no-content-type.html = CRASH
  inspector/debugger/content-providers.html = CRASH
  inspector/debugger/debugger-activation-crash2.html = CRASH
  inspector/debugger/debugger-eval-on-call-frame.html = CRASH
  inspector/debugger/debugger-pause-in-eval-script.html = CRASH
  inspector/debugger/debugger-pause-on-exception.html = CRASH
  inspector/debugger/debugger-scripts.html = CRASH
  inspector/debugger/debugger-step-out.html = CRASH
  inspector/debugger/debugger-suspend-active-dom-objects.html = CRASH
  sputnik/Conformance/07_Lexical_Conventions/7.8_Literals/7.8.5_Regular_Expression_Literals/S7.8.5_A2.1_T2.html = CRASH
Comment 1 Gyuyoung Kim 2015-02-15 01:15:43 PST
I would like to take over this bug. Today result is as below,


Regressions: Unexpected text-only failures (48)
  accessibility/press-targets-center-point.html [ Failure ]
  compositing/backing/replaced-child-no-backing.html [ Failure ]
  compositing/fixed-positioned-pseudo-content-no-compositing.html [ Failure ]
  compositing/geometry/limit-layer-bounds-overflow-root.html [ Failure ]
  compositing/layer-creation/fixed-position-out-of-view-scaled-scroll.html [ Failure ]
  compositing/layer-creation/fixed-position-out-of-view-scaled.html [ Failure ]
  css2.1/t1508-c527-font-00-b.html [ Failure ]
  css3/device-adapt/viewport-width-not-affecting-next-page.html [ Failure ]
  editing/selection/doubleclick-crash.html [ Failure ]
  fast/box-sizing/box-sizing.html [ Failure ]
  fast/css-grid-layout/grid-item-order-in-content-sized-columns-resolution.html [ Failure ]
  fast/css/font-face-default-font.html [ Failure ]
  fast/css/font-face-in-media-rule.html [ Failure ]
  fast/css/fontloader-svg-select.svg [ Failure ]
  fast/css/image-rendering.html [ Failure ]
  fast/css/line-height-determined-by-primary-font.html [ Failure ]
  fast/css/outline-auto-empty-rects.html [ Failure ]
  fast/css/vertical-text-overflow-ellipsis-text-align-center.html [ Failure ]
  fast/dom/Document/CaretRangeFromPoint/hittest-relative-to-viewport.html [ Failure ]
  fast/dom/HTMLImageElement/sizes/image-sizes-js-change.html [ Failure ]
  fast/dom/adopt-node-crash-2.html [ Failure ]
  fast/events/drop-with-file-paths.html [ Failure ]
  fast/forms/basic-buttons.html [ Failure ]
  fast/forms/datalist/datalist-child-validation.html [ Failure ]
  fast/forms/search-vertical-alignment.html [ Failure ]
  fast/forms/searchfield-heights.html [ Failure ]
  fast/forms/textfield-overflow-by-value-update.html [ Failure ]
  fast/line-grid/line-align-right-edges.html [ Failure ]
  fast/repaint/selection-ruby-rl.html [ Failure ]
  fast/sub-pixel/client-width-height-snapping.html [ Failure ]
  fast/sub-pixel/inline-block-with-padding.html [ Failure ]
  fast/sub-pixel/selection/selection-rect-in-sub-pixel-table.html [ Failure ]
  fast/table/022.html [ Failure ]
  fast/text/decorations-with-text-combine.html [ Failure ]
  fast/text/emphasis-combined-text.html [ Failure ]
  fast/text/emphasis-vertical.html [ Failure ]
  fast/text/khmer-lao-font.html [ Failure ]
  fast/text/midword-break-before-surrogate-pair-2.html [ Failure ]
  fast/text/wbr-pre.html [ Failure ]
  fast/text/whitespace/019.html [ Failure ]
  fast/text/whitespace/023.html [ Failure ]
  fast/writing-mode/Kusa-Makura-background-canvas.html [ Failure ]
  http/tests/cache/disk-cache-validation.html [ Failure ]
  http/tests/cache/willsendrequest-returns-null-for-memory-cache-load.html [ Failure ]
  http/tests/misc/authentication-redirect-3/authentication-sent-to-redirect-same-origin-with-location-credentials.html [ Failure ]
  mathml/opentype/horizontal.html [ Failure ]
  svg/text/textPathBoundsBug.svg [ Failure ]
  tables/mozilla/bugs/bug157890.html [ Failure ]

Regressions: Unexpected image-only failures (19)
  compositing/animation/matrix-animation.html [ ImageOnlyFailure ]
  compositing/backing/solid-color-with-paints-into-ancestor.html [ ImageOnlyFailure ]
  compositing/clipping/border-radius-stacking-context-clip.html [ ImageOnlyFailure ]
  compositing/contents-scale/non-decomposable-matrix.html [ ImageOnlyFailure ]
  compositing/hidpi-transform-with-render-layer-on-fractional-pixel-value.html [ ImageOnlyFailure ]
  css1/basic/comments.html [ ImageOnlyFailure ]
  css3/flexbox/csswg/flexbox_direction-row-reverse.html [ ImageOnlyFailure ]
  fast/backgrounds/background-opaque-clipped-gradients.html [ ImageOnlyFailure ]
  fast/borders/0px-borders.html [ ImageOnlyFailure ]
  fast/borders/border-painting-correctness-dashed.html [ ImageOnlyFailure ]
  fast/borders/border-painting-correctness-dotted.html [ ImageOnlyFailure ]
  fast/borders/border-radius-on-html.html [ ImageOnlyFailure ]
  fast/css3-text/css3-text-decoration/text-decoration-skip/decoration-skip-crash-fallback-svg.html [ ImageOnlyFailure ]
  fast/regions/overflow/overflow-region-float.html [ ImageOnlyFailure ]
  fast/regions/overflow/overflow-region-inline.html [ ImageOnlyFailure ]
  fast/ruby/ruby-justification.html [ ImageOnlyFailure ]
  fast/scrolling/scroll-select-list.html [ ImageOnlyFailure ]
  fast/text/narrow-non-breaking-space.html [ ImageOnlyFailure ]
  fast/text/space-width.html [ ImageOnlyFailure ]
Comment 2 Michael Catanzaro 2017-03-11 10:34:03 PST
Closing this bug because the EFL port has been removed from trunk.

If you feel this bug applies to a different upstream WebKit port and was closed in error, please either update the title and reopen the bug, or leave a comment to request this.