Bug 92636 - [Qt][WK1] REGRESSION(r123988) It made fast/writing-mode/flipped-blocks-hit-test-line-edges.html fail
Summary: [Qt][WK1] REGRESSION(r123988) It made fast/writing-mode/flipped-blocks-hit-te...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Marcelo Lira
URL:
Keywords:
: 92639 (view as bug list)
Depends on:
Blocks: 79666 92597
  Show dependency treegraph
 
Reported: 2012-07-30 05:20 PDT by János Badics
Modified: 2012-09-26 01:02 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.46 KB, patch)
2012-09-25 14:38 PDT, Marcelo Lira
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description János Badics 2012-07-30 05:20:04 PDT
r123988 made this test fail on WebKit1. The diff is the following:

--- /ramdisk/qt-linux-64-release/build/layout-test-results/fast/writing-mode/flipped-blocks-hit-test-line-edges-expected.txt 
+++ /ramdisk/qt-linux-64-release/build/layout-test-results/fast/writing-mode/flipped-blocks-hit-test-line-edges-actual.txt 
@@ -7,6 +7,6 @@
 PASS: offset at (160,26) was 26.
 PASS: offset at (60,25) was 24.
 PASS: offset at (160,25) was 26.
-PASS: offset at (60,24) was 26.
+FAIL: offset at (60,24) was 24. Expected 26.
 PASS: offset at (160,24) was 26.
 
You can see the original bug at
​https://bugs.webkit.org/show_bug.cgi?id=92597
Comment 1 Zoltan Arvai 2012-07-30 05:30:08 PDT
*** Bug 92639 has been marked as a duplicate of this bug. ***
Comment 2 Csaba Osztrogonác 2012-07-30 06:18:42 PDT
Skipped by https://trac.webkit.org/changeset/124018, please unskip it with the proper fix.
Comment 3 mitz 2012-07-30 07:16:06 PDT
The test is failing because of the different selection mode used in some non-OS X ports.
Comment 4 Marcelo Lira 2012-09-25 14:38:01 PDT
Created attachment 165677 [details]
Patch
Comment 5 Ryosuke Niwa 2012-09-25 18:42:45 PDT
Does the test pass now? Why can we unskip the test?
Comment 6 Csaba Osztrogonác 2012-09-26 00:58:07 PDT
Comment on attachment 165677 [details]
Patch

It seems it passes now, so let's unskip it.
Comment 7 WebKit Review Bot 2012-09-26 01:02:26 PDT
Comment on attachment 165677 [details]
Patch

Clearing flags on attachment: 165677

Committed r129606: <http://trac.webkit.org/changeset/129606>
Comment 8 WebKit Review Bot 2012-09-26 01:02:29 PDT
All reviewed patches have been landed.  Closing bug.