Bug 76257 - [Win][JSC] Eliminate JavaScriptCore.def
Summary: [Win][JSC] Eliminate JavaScriptCore.def
Status: RESOLVED DUPLICATE of bug 117050
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Hajime Morrita
URL:
Keywords:
Depends on: 92624 92789 92842 92851
Blocks: 27551
  Show dependency treegraph
 
Reported: 2012-01-13 02:01 PST by Hajime Morrita
Modified: 2013-10-31 01:35 PDT (History)
7 users (show)

See Also:


Attachments
Patch to check EWS (64.05 KB, patch)
2012-07-28 00:18 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff
Patch to check EWS (64.70 KB, patch)
2012-07-28 00:34 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff
Patch to check EWS (65.34 KB, patch)
2012-07-28 02:00 PDT, Patrick R. Gansterer
buildbot: commit-queue-
Details | Formatted Diff | Diff
Patch to check EWS (65.87 KB, patch)
2012-07-28 06:12 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff
Patch to check EWS (65.13 KB, patch)
2012-07-28 06:48 PDT, Patrick R. Gansterer
buildbot: commit-queue-
Details | Formatted Diff | Diff
Patch to check EWS (63.45 KB, patch)
2012-07-28 07:47 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hajime Morrita 2012-01-13 02:01:55 PST
This is a twin of Bug 72854.
We now have export macros in the tree.
it should be possible to get rid of the .def file.
Comment 1 Adam Roben (:aroben) 2012-01-13 07:33:48 PST
I wonder if this will change the mangling of exported symbols and thus break nightly builds?
Comment 2 Hajime Morrita 2012-01-15 16:57:51 PST
Hi Adam, thanks for watching this ;-)

> I wonder if this will change the mangling of exported symbols and thus break nightly builds?
I tried it locally and found we need some changes to make it buildable.
The trickiest part is that some WTF string related files are built into WebCore.
We need some workaround for that. I'm investigating better way.

Other fixes will be more trivial - just adding some preprocessor #define-s to compiler options.
Comment 3 Adam Roben (:aroben) 2012-01-17 08:32:18 PST
(In reply to comment #2)
> Hi Adam, thanks for watching this ;-)
> 
> > I wonder if this will change the mangling of exported symbols and thus break nightly builds?
> I tried it locally and found we need some changes to make it buildable.

OK. What I'm wondering though is: once this configuration is "buildable", will nightly builds still work? I.e., will the JavaScriptCore.dll that gets produced using the new process be usable by current versions of Safari?
Comment 4 Hajime Morrita 2012-01-17 17:27:29 PST
(In reply to comment #3)
> OK. What I'm wondering though is: once this configuration is "buildable", will nightly builds still work? I.e., will the JavaScriptCore.dll that gets produced using the new process be usable by current versions of Safari?
Good point. I need to check it locally as a part of this change.
Assuming there is no windows specific JSC API, it should work.
Comment 5 Patrick R. Gansterer 2012-07-28 00:18:27 PDT
Created attachment 155116 [details]
Patch to check EWS
Comment 6 Patrick R. Gansterer 2012-07-28 00:34:39 PDT
Created attachment 155117 [details]
Patch to check EWS
Comment 7 WebKit Review Bot 2012-07-28 00:42:22 PDT
Attachment 155117 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/WTF/wtf/text/AtomicString.h:82:  The parameter name "s" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 10 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 8 Patrick R. Gansterer 2012-07-28 02:00:16 PDT
Created attachment 155122 [details]
Patch to check EWS
Comment 9 WebKit Review Bot 2012-07-28 02:01:46 PDT
Attachment 155122 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/WTF/wtf/text/AtomicString.h:82:  The parameter name "s" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 10 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 10 Build Bot 2012-07-28 05:08:01 PDT
Comment on attachment 155122 [details]
Patch to check EWS

Attachment 155122 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/13370925
Comment 11 Patrick R. Gansterer 2012-07-28 06:12:08 PDT
Created attachment 155126 [details]
Patch to check EWS
Comment 12 WebKit Review Bot 2012-07-28 06:20:33 PDT
Attachment 155126 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/WTF/wtf/text/AtomicString.h:82:  The parameter name "s" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 13 Patrick R. Gansterer 2012-07-28 06:48:03 PDT
Created attachment 155129 [details]
Patch to check EWS
Comment 14 WebKit Review Bot 2012-07-28 06:49:35 PDT
Attachment 155129 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/WTF/wtf/text/AtomicString.h:82:  The parameter name "s" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 15 Build Bot 2012-07-28 07:22:30 PDT
Comment on attachment 155129 [details]
Patch to check EWS

Attachment 155129 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/13374885
Comment 16 Patrick R. Gansterer 2012-07-28 07:47:48 PDT
Created attachment 155130 [details]
Patch to check EWS
Comment 17 Hajime Morrita 2012-07-29 19:51:16 PDT
This is great!!

My picky feeling says WTF_EXPORT_PRIVATE_STRINGSTUFF is too long and strnage.
Something like WTF_EXPORT_STRING_API will be better.
But that's tiny point. This is a big deal. Thanks for taking this!
Comment 18 Patrick R. Gansterer 2013-10-31 01:35:30 PDT

*** This bug has been marked as a duplicate of bug 117050 ***