Bug 41622 - REGRESSION (r62215): Like, Dislike, Save buttons at YouTube don't work
Summary: REGRESSION (r62215): Like, Dislike, Save buttons at YouTube don't work
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Nobody
URL: http://youtube.com
Keywords: GoogleBug, InRadar, Regression
: 41700 42225 42511 43137 43298 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-05 09:57 PDT by CorniMac
Modified: 2010-11-17 16:59 PST (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CorniMac 2010-07-05 09:57:03 PDT
Below the videos on YouTube, there are buttons for Like, Dislike and Save (I hope I get the names right since they aren't english for me, but I think you get which ones I mean, anyway). These don't work properly with WebKit r62241 anymore while they do in the stable Safari 5. The Like- and Dislike-Button give no response when clicked - a message should expand thanking me for my feedback - and the Save-Button opens a menu when clicked, but instead of my playlists etc., it just shows "loading" - it should display my playlists after a little while, but that doesn't happen with r62241.
Comment 1 Alexey Proskuryakov 2010-07-05 14:49:56 PDT
<rdar://problem/8160338>
Comment 2 Alexey Proskuryakov 2010-07-06 12:59:42 PDT
*** Bug 41700 has been marked as a duplicate of this bug. ***
Comment 3 Alexey Proskuryakov 2010-07-06 13:01:02 PDT
Per duplicate, REGRESSION (r61670-r62241).
Comment 4 Alexey Proskuryakov 2010-07-14 12:40:09 PDT
*** Bug 42225 has been marked as a duplicate of this bug. ***
Comment 5 mitz 2010-07-17 20:38:55 PDT
*** Bug 42511 has been marked as a duplicate of this bug. ***
Comment 6 Sam Weinig 2010-07-17 23:38:12 PDT
This is due to Youtube using the Dataset API incorrectly.  They are trying to set element.dataset["tooltip-title"] but the name passed there is not allowed to have a hyphen according to the specification.
Comment 7 Alexey Proskuryakov 2010-08-02 08:36:21 PDT
*** Bug 43298 has been marked as a duplicate of this bug. ***
Comment 8 Alexey Proskuryakov 2010-08-02 12:33:34 PDT
*** Bug 43137 has been marked as a duplicate of this bug. ***
Comment 9 Darin Adler 2010-09-08 12:52:59 PDT
Can someone contact YouTube? Maybe someone at Google would have some pull with them or know the right person to talk to?
Comment 10 Dimitri Glazkov (Google) 2010-09-08 14:40:23 PDT
(In reply to comment #9)
> Can someone contact YouTube? Maybe someone at Google would have some pull with them or know the right person to talk to?

I'll reach out to them.
Comment 11 Dimitri Glazkov (Google) 2010-09-10 06:55:40 PDT
(In reply to comment #10)
> (In reply to comment #9)
> > Can someone contact YouTube? Maybe someone at Google would have some pull with them or know the right person to talk to?
> 
> I'll reach out to them.

They will fix this next week.
Comment 12 Sam Weinig 2010-11-17 16:59:43 PST
This appears to be fixed on their end.