RESOLVED FIXED 41374
Rename releaseRef to leakRef
https://bugs.webkit.org/show_bug.cgi?id=41374
Summary Rename releaseRef to leakRef
Darin Adler
Reported 2010-06-29 14:18:26 PDT
Rename the releaseRef function in PassRefPtr to leakRef. Might also want to add a leakRef function to RefPtr.
Attachments
David Kilzer (:ddkilzer)
Comment 1 2010-09-27 14:59:21 PDT
There is also a releaseRef() method defined in RetainPtr.h.
Darin Adler
Comment 2 2010-09-27 15:01:51 PDT
JSRetainPtr.h, PassRefPtr.h, RetainPtr.h, and COMPtr.h all now have leakRef functions. But many old call sites still are calling releaseRef, so we still have releaseRef functions in all of these classes that call over to leakRef. Remaining work: Switch all the call sites to leakRef, and delete releaseRef functions entirely.
Note You need to log in before you can comment on or make changes to this bug.