Bug 13658 - getPropertyValue on CSSComputedStyleDeclaration should return shorthand values
Summary: getPropertyValue on CSSComputedStyleDeclaration should return shorthand values
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P3 Enhancement
Assignee: Alexis Menard (darktears)
URL:
Keywords:
: 7703 (view as bug list)
Depends on: 74635 74743 75312 75319 75347 75352 75358 75434 75443 75539 75630
Blocks: 14397
  Show dependency treegraph
 
Reported: 2007-05-10 09:44 PDT by Timothy Hatcher
Modified: 2012-01-10 08:46 PST (History)
2 users (show)

See Also:


Attachments
Test case (443 bytes, text/html)
2007-05-10 09:45 PDT, Timothy Hatcher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2007-05-10 09:44:06 PDT
I have a change to the Web Inspector that smartly groups computed style properties under their short hand name. Except I rely on the engine's CSSComputedStyleDeclaration to give me a value if I pass it a shorthand name.

Similar to how CSSMutableStyleDeclaration will generate a shorthand value if you pass in a shorthand property name. However, shorthands should not be in the enumerable property list (just like CSSMutableStyleDeclaration).

See attached test case.
Comment 1 Timothy Hatcher 2007-05-10 09:45:39 PDT
Created attachment 14472 [details]
Test case

Note, Firefox doesn't support this either. However, I don't think it would cause compatibility problems adding it to WebKit.
Comment 2 Mark Rowe (bdash) 2007-08-26 22:22:45 PDT
*** Bug 7703 has been marked as a duplicate of this bug. ***
Comment 3 Alexis Menard (darktears) 2012-01-10 08:46:09 PST
It's safe to close it. I guess all common shorthand values are correctly return now.