Bug 103009 - It should be possible to say dataLog("count = ", count, "\n") instead of dataLogF("count = %d\n", count)
Summary: It should be possible to say dataLog("count = ", count, "\n") instead of data...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on: 103000 103001
Blocks: 102999 103492
  Show dependency treegraph
 
Reported: 2012-11-21 19:22 PST by Filip Pizlo
Modified: 2012-11-28 15:04 PST (History)
14 users (show)

See Also:


Attachments
WRONG PATCH (43.56 KB, patch)
2012-11-21 20:11 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff
the patch (21.40 KB, patch)
2012-11-28 00:58 PST, Filip Pizlo
msaboff: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2012-11-21 19:22:23 PST
And we should also be able to provide overloads for logging objects by just overloading some print() function.
Comment 1 Filip Pizlo 2012-11-21 20:11:44 PST
Created attachment 175572 [details]
WRONG PATCH
Comment 2 Filip Pizlo 2012-11-21 20:12:34 PST
Comment on attachment 175572 [details]
WRONG PATCH

Ooops.  I posted this to the wrong bug. :-/
Comment 3 Filip Pizlo 2012-11-28 00:58:01 PST
Created attachment 176419 [details]
the patch

For reals this time.
Comment 4 Filip Pizlo 2012-11-28 15:04:19 PST
Landed in http://trac.webkit.org/changeset/136066