Bug 42025

Summary: 1336 files in WebCore rebuild when you touch SVGNames
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: WebCore Misc.Assignee: Nikolas Zimmermann <zimmermann>
Status: RESOLVED FIXED    
Severity: Normal CC: dumi, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on: 47905, 50316, 50322, 50323, 50383, 50440    
Bug Blocks:    
Attachments:
Description Flags
Patch krit: review+

Description Eric Seidel (no email) 2010-07-10 02:12:02 PDT
1336 files in WebCore rebuild when you touch SVGNames

Something in the dependency chain is very broken.
Comment 1 Eric Seidel (no email) 2010-07-10 02:13:00 PDT
I think this is mostly caused by DECLARE_ANIMATED_PROPERTY taking a QualifiedName parameter.

WildFox says that parameter isn't even used anymore.

This could be a noticeable codesize reduction in the intermediate files.  SVGNames.h is not a small include.
Comment 2 Eric Seidel (no email) 2010-07-10 23:26:38 PDT
    PassRefPtr<SVGAnimatedPropertyTearOff##UpperProperty> LowerProperty##Animated() \
    { \
        SVGElement* contextElement = GetOwnerElementForType<OwnerType, IsDerivedFromSVGElement<OwnerType>::value>::ownerElement(this); \
        return lookupOrCreateWrapper<AnimatedType, SVGAnimatedPropertyTearOff##UpperProperty>(contextElement, m_##LowerProperty, DOMAttribute); \
    }

Still uses DOMAttribute from the _DECLARE macro.  Seems we'll need to move that to the .cpp if we want to get rid of this crazy SVGNames sprawl.
Comment 3 Nikolas Zimmermann 2010-12-01 02:07:06 PST
Now that 47905 is completly fixed, I'm working on removing the SVGNames.h dependency, a first patch covering SVGLength will be uploaded soon.
Comment 4 Nikolas Zimmermann 2010-12-03 03:00:28 PST
Created attachment 75485 [details]
Patch
Comment 5 Dirk Schulze 2010-12-03 03:02:56 PST
Comment on attachment 75485 [details]
Patch

LGTM. r=me
Comment 6 Nikolas Zimmermann 2010-12-03 03:15:02 PST
Landed in r73258, hopefully making Eric happy :-)
Comment 7 Eric Seidel (no email) 2010-12-03 08:35:00 PST
Yay!