Bug 149243

Summary: Make event dispatching respect slotting
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: UI EventsAssignee: Ryosuke Niwa <rniwa>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, commit-queue, eoconnor, esprehn+autocc, kangil.han, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 149241, 149488    
Bug Blocks: 148695    
Attachments:
Description Flags
Implements the basic dispatching
none
Patch for landing none

Description Ryosuke Niwa 2015-09-16 18:13:07 PDT
Make event dispatching code respect the slotting added in the bug 149241.
Comment 1 Radar WebKit Bug Importer 2015-09-17 18:12:03 PDT
<rdar://problem/22750923>
Comment 2 Ryosuke Niwa 2015-09-19 02:14:27 PDT
*** Bug 149324 has been marked as a duplicate of this bug. ***
Comment 3 Ryosuke Niwa 2015-09-23 18:21:34 PDT
Created attachment 261857 [details]
Implements the basic dispatching
Comment 4 Andreas Kling 2015-09-24 10:14:51 PDT
Comment on attachment 261857 [details]
Implements the basic dispatching

View in context: https://bugs.webkit.org/attachment.cgi?id=261857&action=review

r=me too

> Source/WebCore/dom/EventDispatcher.cpp:433
> +        Node* parent;

Could this be a ContainerNode*?

> Source/WebCore/dom/EventDispatcher.cpp:451
> +                if (auto assignedSlot = shadowRootOfParent->findAssignedSlot(*node)) {

We use auto* for pointers rather than auto, I think.

> Source/WebCore/dom/EventDispatcher.cpp:452
> +                    // node is assgined to a slot. Continue dispatching the event at this slot.

Typo, assigned.
Comment 5 Ryosuke Niwa 2015-09-24 11:08:59 PDT
Created attachment 261877 [details]
Patch for landing
Comment 6 WebKit Commit Bot 2015-09-24 12:00:32 PDT
Comment on attachment 261877 [details]
Patch for landing

Clearing flags on attachment: 261877

Committed r190214: <http://trac.webkit.org/changeset/190214>
Comment 7 WebKit Commit Bot 2015-09-24 12:00:37 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Brent Fulgham 2015-09-29 10:54:26 PDT
This change *may* have introduced Windows regressions (see https://bugs.webkit.org/show_bug.cgi?id=149632).