Bug 135290
Summary: | Rename FontData and friends to better names | ||
---|---|---|---|
Product: | WebKit | Reporter: | Myles C. Maxfield <mmaxfield> |
Component: | Layout and Rendering | Assignee: | Myles C. Maxfield <mmaxfield> |
Status: | NEW | ||
Severity: | Normal | CC: | darin, koivisto |
Priority: | P2 | ||
Version: | 528+ (Nightly build) | ||
Hardware: | Unspecified | ||
OS: | Unspecified | ||
Bug Depends on: | 140124, 140442, 140496 | ||
Bug Blocks: |
Myles C. Maxfield
Font represents a CSS font, not a platform font. A FontData is either one or a collection of SimpleFontData objects. SimpleFontData has a function called fontData() which returns AdditionalFontData and a member variable of type DerivedFontData. These names are confusing.
Attachments | ||
---|---|---|
Add attachment proposed patch, testcase, etc. |
Antti Koivisto
Maybe something like:
Font -> CompositeFont
SimpleFontData -> Font
SegmentedFontData -> SegmentedFont
FontData -> FontBase (eliminating the inheritance here would be good)
AdditionalFontData -> SVGFontCallback (no need to be coy)
SimpleFontData::fontData() -> SimpleFontData::svgFontCallback()