RESOLVED FIXED 140124
Rename SimpleFontData::AdditionalFontData to SimpleFontData::SVGData
https://bugs.webkit.org/show_bug.cgi?id=140124
Summary Rename SimpleFontData::AdditionalFontData to SimpleFontData::SVGData
Antti Koivisto
Reported 2015-01-06 07:32:34 PST
The current name is vague and confusing.
Attachments
patch (10.43 KB, patch)
2015-01-06 07:45 PST, Antti Koivisto
andersca: review+
Antti Koivisto
Comment 1 2015-01-06 07:45:40 PST
Myles C. Maxfield
Comment 2 2015-01-06 09:39:37 PST
Comment on attachment 244061 [details] patch View in context: https://bugs.webkit.org/attachment.cgi?id=244061&action=review > Source/WebCore/platform/graphics/SimpleFontData.h:179 > + bool isSVGFont() const { return !!m_svgData; } Is the !! necessary? Won't the bool cast be automatic?
Anders Carlsson
Comment 3 2015-01-06 09:41:38 PST
Comment on attachment 244061 [details] patch View in context: https://bugs.webkit.org/attachment.cgi?id=244061&action=review >> Source/WebCore/platform/graphics/SimpleFontData.h:179 >> + bool isSVGFont() const { return !!m_svgData; } > > Is the !! necessary? Won't the bool cast be automatic? It won't since the std::unique_ptr bool operator is explicit.
Antti Koivisto
Comment 4 2015-01-06 11:22:12 PST
Note You need to log in before you can comment on or make changes to this bug.