Bug 96056 - [EFL] Enable MEDIA_STREAM
Summary: [EFL] Enable MEDIA_STREAM
Status: RESOLVED DUPLICATE of bug 87662
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-06 19:36 PDT by Gyuyoung Kim
Modified: 2012-09-06 22:02 PDT (History)
2 users (show)

See Also:


Attachments
the snip error info (28.03 KB, text/plain)
2012-09-06 20:02 PDT, Dennis Lan
no flags Details
add missing files fix this problem (1.99 KB, patch)
2012-09-06 20:40 PDT, Dennis Lan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gyuyoung Kim 2012-09-06 19:36:28 PDT
EFL port doesn't support Media Stream feature yet.
Comment 1 Dennis Lan 2012-09-06 20:02:29 PDT
Created attachment 162658 [details]
the snip error info

../../../lib/libwebcore_efl.a(MediaStreamTrack.cpp.o): In function `WebCore::MediaStreamTrack::~MediaStreamTrack()':
MediaStreamTrack.cpp:(.text+0x4f5): undefined reference to `WebCore::MediaStreamSource::removeObserver(WebCore::MediaStreamSource::Observer*)'
../../../lib/libwebcore_efl.a(MediaStreamTrack.cpp.o): In function `WebCore::MediaStreamTrack::MediaStreamTrack(WebCore::ScriptExecutionContext*, WTF::PassRefPtr<WebCore::MediaStreamDescriptor>, WebCore::MediaStreamComponent*)':



the problem is due to Source/WebCore/platform/mediastream/MediaStreamSource.cpp not enabled,
and when compare to Source/WebCore/GNUmakefile.list.am, Source/WebCore/CMakeList.txt missing a few files from directory Source/WebCore/platform/mediastream/
Comment 2 Dennis Lan 2012-09-06 20:40:27 PDT
Created attachment 162662 [details]
add missing files fix this problem

I've blindly copy missing files from GNUMakefile.list.am, adjust it if you think necessary
Comment 3 Gyuyoung Kim 2012-09-06 21:29:13 PDT


http://www.webkit.org/coding/contributing.html
Comment 4 Gyuyoung Kim 2012-09-06 21:32:38 PDT
(In reply to comment #3)

Dennis Lan, you should read webkit contribution page first. Your patch doesn't follow webkit patch style.

http://www.webkit.org/coding/contributing.html

I think that your patch is just for fixing build break. So, I think you have to submit your patch to Bug 96063 instead. This bug needs to do something further to enable MEDIA_STREAM feature.
Comment 5 Chris Dumez 2012-09-06 21:45:01 PDT
Duplicate of Bug 87662?
Comment 6 Gyuyoung Kim 2012-09-06 22:01:34 PDT
Yes, right(In reply to comment #5)
> Duplicate of Bug 87662?

Ah, yes, right.

*** This bug has been marked as a duplicate of bug 87662 ***