Bug 95070 - REGRESSION(r126717): It made inspector/styles/media-queries.html fail/flakey
Summary: REGRESSION(r126717): It made inspector/styles/media-queries.html fail/flakey
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
: 95066 (view as bug list)
Depends on:
Blocks: 94926 79666
  Show dependency treegraph
 
Reported: 2012-08-27 03:46 PDT by Dominic Cooney
Modified: 2012-09-14 12:04 PDT (History)
14 users (show)

See Also:


Attachments
rollout (33.88 KB, patch)
2012-09-14 10:36 PDT, Alexey Proskuryakov
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Cooney 2012-08-27 03:46:21 PDT
Per the flakiness dashboard, this has been failing reliably on Linux (debug) since r126717:

<http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=inspector%2Fstyles%2Fmedia-queries.html>

It also became flaky on Linux, Linux 32 and Win (dbg) around that revision.
Comment 1 Csaba Osztrogonác 2012-08-27 05:55:38 PDT
It isn't chromium specific bug at all, this test started to fail
on Qt 32 bit release too:

--- /ramdisk/qt-linux-release/build/layout-test-results/inspector/styles/media-queries-expected.txt 
+++ /ramdisk/qt-linux-release/build/layout-test-results/inspector/styles/media-queries-actual.txt 
@@ -14,8 +14,8 @@
 [expanded] 
 media="all" (media-queries.html)
 @import screen (media-queries.css:3)
-@media not aural (media-queries-1.css:5)
-#main  { (media-queries-1.css:6)
+@media not aural (resources/media-queries-1.css:5)
+#main  { (resources/media-queries-1.css:6)
 border: 1px solid black;
 
 [expanded] 


It's strange, but it passes in debug mode and on 64 bit platforms.
Comment 2 Csaba Osztrogonác 2012-08-27 06:32:36 PDT
Skipped on Qt by https://trac.webkit.org/changeset/126753
Please unskip it with the proper fix.
Comment 3 Csaba Osztrogonác 2012-08-31 07:11:00 PDT
Antti, Kling? Could you check this regression you caused, please?
Comment 4 Csaba Osztrogonác 2012-09-04 08:16:33 PDT
(In reply to comment #3)
> Antti, Kling? Could you check this regression you caused, please?

ping again ...
Comment 5 Csaba Osztrogonác 2012-09-05 23:09:16 PDT
ping again and again ... Are you going to fix the regression you caused?
Comment 6 Antti Koivisto 2012-09-06 06:35:19 PDT
This seems like some timing related bug in the inspector or inspector test harness. I couldn't really figure out what that test is doing. Maybe apavlov has ideas what this could be about?
Comment 7 Alexander Pavlov (apavlov) 2012-09-09 23:13:27 PDT
(In reply to comment #6)
> This seems like some timing related bug in the inspector or inspector test harness. I couldn't really figure out what that test is doing. Maybe apavlov has ideas what this could be about?

As to the test, it makes sure the media query "stack" is dumped for each matched CSS rule (if applicable).

Now, I have little knowledge about this particular type of flakiness, but we've seen it occasionally for multiple types of tests that involved building/dumping links for resource URLs. IIRC, some time ago it was a result of the main resource loading not finished by the moment a URL linkification took place. Not sure about the current reason though, as much have changed in this area since then (I remember at least one attempt to fix it by a change to the test harness).
Comment 8 Alexey Proskuryakov 2012-09-13 15:51:34 PDT
> It's strange, but it passes in debug mode and on 64 bit platforms.

This happens on Mac (debug, 64-bit), too:

http://build.webkit.org/results/Apple%20Lion%20Debug%20WK2%20(Tests)/r128507%20(3413)/inspector/styles/media-queries-pretty-diff.html

Should we roll out r126717 to confirm that it's indeed the revision causing this?
Comment 9 Alexey Proskuryakov 2012-09-14 10:36:08 PDT
Created attachment 164187 [details]
rollout

Since it's been several weeks without much progress, I'm going to roll out once EWS reports green. There was one other patch that depended on this change, and it also gets rolled out.
Comment 10 WebKit Review Bot 2012-09-14 10:38:04 PDT
Attachment 164187 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1
Source/WebCore/css/StyleRuleImport.cpp:108:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 11 Alexey Proskuryakov 2012-09-14 11:06:33 PDT
*** Bug 95066 has been marked as a duplicate of this bug. ***
Comment 12 Alexey Proskuryakov 2012-09-14 11:16:51 PDT
I could reproduce the flakiness locally when running this test alone, and rollout resolved that.

run-webkit-tests inspector/styles/media-queries.html --repeat-each 100 -v
Comment 13 WebKit Review Bot 2012-09-14 11:54:07 PDT
Comment on attachment 164187 [details]
rollout

Rejecting attachment 164187 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 1

ERROR: /mnt/git/webkit-commit-queue/LayoutTests/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: http://queues.webkit.org/results/13854528
Comment 14 Alexey Proskuryakov 2012-09-14 12:04:24 PDT
Committed manually in <http://trac.webkit.org/changeset/128637>.