Bug 93615 - [V8] Introduce V8DOMConfiguration class and make batchConfigureXXX() methods static
Summary: [V8] Introduce V8DOMConfiguration class and make batchConfigureXXX() methods ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
Depends on:
Blocks: 93095
  Show dependency treegraph
 
Reported: 2012-08-09 05:54 PDT by Kentaro Hara
Modified: 2012-08-10 16:19 PDT (History)
7 users (show)

See Also:


Attachments
Patch (58.20 KB, patch)
2012-08-09 19:51 PDT, Kentaro Hara
no flags Details | Formatted Diff | Diff
Patch (57.75 KB, patch)
2012-08-09 20:20 PDT, Kentaro Hara
no flags Details | Formatted Diff | Diff
patch for landing (57.90 KB, patch)
2012-08-10 06:24 PDT, Kentaro Hara
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2012-08-09 05:54:42 PDT
Per the discussion in bug 93239,

(1) Rename V8ConfigureDOMAttributesAndMethods to V8DOMConfiguration.
(2) Introduce V8DOMConfiguration class and make batchConfigureXXX() methods static.
Comment 1 Kentaro Hara 2012-08-09 19:51:10 PDT
Created attachment 157617 [details]
Patch
Comment 2 Kentaro Hara 2012-08-09 20:20:33 PDT
Created attachment 157622 [details]
Patch
Comment 3 Adam Barth 2012-08-10 00:56:39 PDT
Comment on attachment 157622 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=157622&action=review

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:37
> +                                                  v8::Handle<v8::ObjectTemplate> proto, 

I would clean up all these names too.  e.g., proto -> prototype

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:67
> +v8::Local<v8::Signature> V8DOMConfiguration::configureTemplate(v8::Persistent<v8::FunctionTemplate> desc,

desc -> functionDescriptor

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:68
> +                                                               const char *interfaceName,

"const char *" -> "const char*"

> Source/WebCore/bindings/v8/V8DOMConfiguration.cpp:70
> +                                                               int fieldCount,

int -> size_t ?

> Source/WebCore/bindings/v8/V8DOMConfiguration.h:53
> +        bool onProto;

onProto -> onPrototype

> Source/WebCore/bindings/v8/V8DOMConfiguration.h:63
> +                                          v8::Handle<ObjectOrTemplate> proto,

proto -> prototype

> Source/WebCore/bindings/v8/V8DOMConfiguration.h:65
> +        {

Bad indent
Comment 4 Kentaro Hara 2012-08-10 06:24:24 PDT
Created attachment 157726 [details]
patch for landing
Comment 5 WebKit Review Bot 2012-08-10 10:03:31 PDT
Comment on attachment 157726 [details]
patch for landing

Clearing flags on attachment: 157726

Committed r125295: <http://trac.webkit.org/changeset/125295>