Per Dave's suggestion, here is the context:
All block-level elements that can act as containing blocks are RenderBlocks. This includes flexbox, grid, tables, etc.
It would probably be less confusing if "block layout" was pulled into a subclass, e.g., RenderBlockFlow. Then the base class would only hold things common to all the subclasses instead of having the "block layout" system shoved in there as well.