Bug 81891 - [EFL] DRT should support LayoutTestController's dumpResourceLoadCallbacks()
: [EFL] DRT should support LayoutTestController's dumpResourceLoadCallbacks()
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: Unspecified Linux
: P2 Normal
Assigned To:
:
:
: 82192 82437 82443 84670
: 82704 82722 82848 84129 84941
  Show dependency treegraph
 
Reported: 2012-03-22 04:44 PST by
Modified: 2012-05-06 22:49 PST (History)


Attachments
Proposed patch (31.29 KB, patch)
2012-03-29 23:20 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Proposed patch (31.29 KB, patch)
2012-03-30 01:25 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Proposed patch (33.67 KB, patch)
2012-03-30 04:20 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Proposed patch (34.95 KB, patch)
2012-04-10 22:39 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Proposed patch (33.02 KB, patch)
2012-04-17 00:40 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Proposed patch (33.75 KB, patch)
2012-04-17 04:03 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Patch (34.87 KB, patch)
2012-04-20 00:21 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Patch (23.76 KB, patch)
2012-04-26 01:41 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-03-22 04:44:13 PST
EFL DRT does not obey dumpResourceLoadCallbacks() issued by tests - 
HTTP callbacks should be caught and resource load log dumps should be perfomed.

cmp. GTK's willSendRequestCallback, didReceiveResponse, didFinishLoading, didFailLoadingWithError in GTK DumpRenderTree.cpp.
------- Comment #1 From 2012-03-29 23:17:20 PST -------
*** Bug 82437 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2012-03-29 23:20:10 PST -------
Created an attachment (id=134728) [details]
Proposed patch

Implements full support in EFL's DRT for LayoutTestController's dumpResourceLoadCallbacks() and allows for the following test cases to be removed from the skip list:
  http/tests/misc/favicon-loads-with-icon-loading-override.html
  fast/loader/main-document-url-for-non-http-loads.html
  http/tests/misc/link-rel-icon-beforeload.html
  http/tests/misc/willCacheResponse-delegate-callback.html
  http/tests/misc/window-dot-stop.html
  http/tests/security/XFrameOptions/x-frame-options-deny-meta-tag-in-body.html
  http/tests/security/XFrameOptions/x-frame-options-deny-meta-tag-parent-same-origin-allow.html
  http/tests/security/XFrameOptions/x-frame-options-deny-meta-tag-parent-same-origin-deny.html
  http/tests/security/XFrameOptions/x-frame-options-deny-meta-tag.html
  http/tests/security/XFrameOptions/x-frame-options-deny.html
  http/tests/security/XFrameOptions/x-frame-options-parent-same-origin-allow.html
  http/tests/security/XFrameOptions/x-frame-options-parent-same-origin-deny.html
  http/tests/xmlhttprequest/abort-should-cancel-load.html
------- Comment #3 From 2012-03-30 01:25:39 PST -------
Created an attachment (id=134743) [details]
Proposed patch

willSendRequest should be dumped even if willSendRequestReturnsNull is set. Fixed the patch to reflect this.
------- Comment #4 From 2012-03-30 04:20:27 PST -------
Created an attachment (id=134770) [details]
Proposed patch

Updated the patch to address the following issues:
- Should not dump NSError failing url if empty
- Use different domains for WebKit and NSURL errors (Optimally, error domains and codes should move to their own header at some point)
------- Comment #5 From 2012-04-10 18:08:22 PST -------
(From update of attachment 134770 [details])
Could you rebase and upload this? It looks the patch was uploaded in unfortunate timing by which bot didn't pick the patch.
The change itself looks sane.
------- Comment #6 From 2012-04-10 22:39:48 PST -------
Created an attachment (id=136623) [details]
Proposed patch

Rebase on master
------- Comment #7 From 2012-04-17 00:40:42 PST -------
Created an attachment (id=137487) [details]
Proposed patch

Rebased on master and split with #84129 to reduce patch size.
------- Comment #8 From 2012-04-17 00:53:34 PST -------
(From update of attachment 137487 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=137487&action=review

> Source/WebKit/efl/ChangeLog:9
> +        Implement support for LayoutTestController's 
> +        dumpResourceLoadCallbacks() in EFL's DumpRenderTree.

Description in ChangeLog is poor beside patch size.

> Tools/ChangeLog:9
> +        dumpResourceLoadCallbacks() in EFL's DumpRenderTree.

ditto.
------- Comment #9 From 2012-04-17 04:03:38 PST -------
Created an attachment (id=137509) [details]
Proposed patch

Improve Changelogs' descriptions based on Gyuyoung Kim's feedback.
------- Comment #10 From 2012-04-20 00:21:32 PST -------
Created an attachment (id=138053) [details]
Patch

Rebase on master.
------- Comment #11 From 2012-04-23 23:17:06 PST -------
Splitting with 84670 to facilitate review.
------- Comment #12 From 2012-04-26 01:41:39 PST -------
Created an attachment (id=138951) [details]
Patch

Rebase on master now that patch from bug 84670 has landed.
------- Comment #13 From 2012-04-27 00:54:50 PST -------
(From update of attachment 138951 [details])
It looks there is no critical problem. Looks fine.
------- Comment #14 From 2012-04-27 02:46:19 PST -------
(From update of attachment 138951 [details])
Clearing flags on attachment: 138951

Committed r115415: <http://trac.webkit.org/changeset/115415>
------- Comment #15 From 2012-04-27 02:46:26 PST -------
All reviewed patches have been landed.  Closing bug.