Bug 7763 - Empty action URIs in Forms redirect towards site root and not same document
: Empty action URIs in Forms redirect towards site root and not same document
Status: RESOLVED DUPLICATE of bug 19884
Product: WebKit
Classification: Unclassified
Component: Forms
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-14 05:10 PST by Olivier Le Floch
Modified: 2009-03-20 01:47 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Le Floch 2006-03-14 05:10:18 PST
It would seem, according to rfc3986, §4.4, that an empty URI action for a html form, such as
<form action="">
is supposed to redirect towards the same document.

Several other browsers act in this manner, but Webkit redirects towards the base location of the web site.

This bug is present on http://frankiz.net/, however the site is not open for user registration.

This bug poses a problem for websites that are visible from several locations with different access paths (proxypass for instance).
Comment 1 David Kilzer (:ddkilzer) 2006-03-14 08:57:28 PST
This may or may not be related to Bug 6958.
Comment 2 Alexey Proskuryakov 2006-03-14 13:16:27 PST
Test case: <http://nypop.com/~ap/webkit/submit-empty.html>.
Comment 3 Alexey Proskuryakov 2007-11-23 01:57:56 PST
I have lost my reduction, and cannot re-create it, even with original 10.4.10 WebKit.
Comment 4 crisp 2009-03-19 17:37:42 PDT
This still seems to be an issue since we received a simular bugreport for our site where we used action="" in combination with a <base href> pointing to the root of our site.

According to HTML5 (and in line with other browser's behaviour) the empty string for the action attribute should be treated as a same-document reference ( http://www.w3.org/TR/html5/forms.html#form-submission-algorithm ). Webkit apparently still fails to do so and uses the base url in such case.

At least these bugs seem to be duplicates/related:

https://bugs.webkit.org/show_bug.cgi?id=18166
https://bugs.webkit.org/show_bug.cgi?id=20378

Imo this bug should be upped as a (future) spec-violation and an interoperability issue.
Comment 5 Alexey Proskuryakov 2009-03-20 01:41:02 PDT
Can you still reproduce the problem with Safari 4 beta?
Comment 6 Alexey Proskuryakov 2009-03-20 01:47:50 PDT
This should have been fixed in bug 19884, please feel free to re-open if you can still reproduce this with Safari 4 beta.

*** This bug has been marked as a duplicate of 19884 ***