Bug 76340 - [Qt] Fix QT_VERSION related warnings when building on Mac OS X
Summary: [Qt] Fix QT_VERSION related warnings when building on Mac OS X
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified OS X 10.7
: P2 Normal
Assignee: Zeno Albisser
URL:
Keywords:
: 76175 (view as bug list)
Depends on:
Blocks: 76341
  Show dependency treegraph
 
Reported: 2012-01-14 12:48 PST by Alexander Færøy
Modified: 2012-01-20 07:01 PST (History)
5 users (show)

See Also:


Attachments
Patch (1.26 KB, patch)
2012-01-14 13:01 PST, Alexander Færøy
ahf: review-
ahf: commit-queue-
Details | Formatted Diff | Diff
patch for review. (12.64 KB, patch)
2012-01-16 09:03 PST, Zeno Albisser
vestbo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Færøy 2012-01-14 12:48:25 PST
wtf/Platform.h uses QT_VERSION when build on darwin, but does not include the QtGlobals header. This is required to be fixed before we can enable -Werror on the Mac platform.

Patch coming up.
Comment 1 Alexander Færøy 2012-01-14 13:01:43 PST
Created attachment 122556 [details]
Patch
Comment 2 Alexander Færøy 2012-01-14 13:02:42 PST
Adding Tor Arne for review.
Comment 3 Noam Rosenthal 2012-01-14 20:35:03 PST
It looked pretty trivial to me, but if torarne wants to have a look it might be good because those builds tend to get fudged
Comment 4 Alexander Færøy 2012-01-14 20:36:13 PST
(In reply to comment #3)
> It looked pretty trivial to me, but if torarne wants to have a look it might be good because those builds tend to get fudged

Aye, I am just holding on with the CQ? until monday where other people are around too :-)
Comment 5 Alexander Færøy 2012-01-16 04:08:26 PST
Comment on attachment 122556 [details]
Patch

CQ?
Comment 6 Zeno Albisser 2012-01-16 08:29:25 PST
This bug was caused by r104826.

We should revert r104826 and solve the problem as described here:
see also: https://bugs.webkit.org/show_bug.cgi?id=57239
Comment 7 Tor Arne Vestbø 2012-01-16 08:54:07 PST
(In reply to comment #6)
> This bug was caused by r104826.
> 
> We should revert r104826 and solve the problem as described here:
> see also: https://bugs.webkit.org/show_bug.cgi?id=57239

Sounds good!
Comment 8 Zeno Albisser 2012-01-16 09:03:44 PST
Created attachment 122650 [details]
patch for review.
Comment 9 Zeno Albisser 2012-01-16 10:17:53 PST
Committed r105074: <http://trac.webkit.org/changeset/105074>
Comment 10 Zeno Albisser 2012-01-20 07:01:02 PST
*** Bug 76175 has been marked as a duplicate of this bug. ***