WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
69828
Move the content of SelectElementData into HTMLSelectElement, and remove SelectElement.{cpp,h}
https://bugs.webkit.org/show_bug.cgi?id=69828
Summary
Move the content of SelectElementData into HTMLSelectElement, and remove Sele...
Kent Tamura
Reported
2011-10-11 03:30:56 PDT
Move the content of SelectElementData into HTMLSelectElement, and remove SelectElement.{cpp,h}
Attachments
Patch
(45.50 KB, patch)
2011-10-11 03:38 PDT
,
Kent Tamura
no flags
Details
Formatted Diff
Diff
Patch 2
(46.73 KB, patch)
2011-10-11 05:51 PDT
,
Kent Tamura
darin
: review+
Details
Formatted Diff
Diff
Show Obsolete
(1)
View All
Add attachment
proposed patch, testcase, etc.
Kent Tamura
Comment 1
2011-10-11 03:38:35 PDT
Created
attachment 110493
[details]
Patch
Gustavo Noronha (kov)
Comment 2
2011-10-11 04:44:49 PDT
Comment on
attachment 110493
[details]
Patch
Attachment 110493
[details]
did not pass gtk-ews (gtk): Output:
http://queues.webkit.org/results/10027494
Collabora GTK+ EWS bot
Comment 3
2011-10-11 05:26:38 PDT
Comment on
attachment 110493
[details]
Patch
Attachment 110493
[details]
did not pass gtk-ews (gtk): Output:
http://queues.webkit.org/results/10031417
Kent Tamura
Comment 4
2011-10-11 05:51:46 PDT
Created
attachment 110503
[details]
Patch 2 Probably fixed GTK and Windows bulid
Darin Adler
Comment 5
2011-10-11 08:40:19 PDT
Comment on
attachment 110503
[details]
Patch 2 View in context:
https://bugs.webkit.org/attachment.cgi?id=110503&action=review
> Source/WebCore/html/HTMLSelectElement.h:164 > + bool usesMenuList() const > + { > +#if ENABLE(NO_LISTBOX_RENDERING) > + return true; > +#else > + return !m_multiple && m_size <= 1; > +#endif > + }
It’s good to have this inline, but it’s a little long and ugly to have here in the class definition. I’d put it separately after the class definition.
> Source/WebCore/html/HTMLSelectElement.h:178 > Vector<Element*> m_listItems;
These should be HTMLFormControlElement*. The only reason they are Element* was WML support.
> Source/WebCore/html/HTMLSelectElement.h:191 > bool m_recalcListItems;
I think this should be renamed (later) m_shouldRecalcListItems or something even better.
Kent Tamura
Comment 6
2011-10-12 00:10:19 PDT
Comment on
attachment 110503
[details]
Patch 2 View in context:
https://bugs.webkit.org/attachment.cgi?id=110503&action=review
>> Source/WebCore/html/HTMLSelectElement.h:164 >> + } > > It’s good to have this inline, but it’s a little long and ugly to have here in the class definition. I’d put it separately after the class definition.
ok, I move it.
>> Source/WebCore/html/HTMLSelectElement.h:178 >> Vector<Element*> m_listItems; > > These should be HTMLFormControlElement*. The only reason they are Element* was WML support.
Unfortunately, m_listItems contains <hr> elements. We can change Element* to HTMLElement*.
>> Source/WebCore/html/HTMLSelectElement.h:191 >> bool m_recalcListItems; > > I think this should be renamed (later) m_shouldRecalcListItems or something even better.
I'll address this later.
Kent Tamura
Comment 7
2011-10-12 00:13:19 PDT
Committed
r97238
: <
http://trac.webkit.org/changeset/97238
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug