Bug 63793 - new-run-webkit-tests output gets confused when logging
Summary: new-run-webkit-tests output gets confused when logging
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
: 67164 (view as bug list)
Depends on:
Blocks: 64491
  Show dependency treegraph
 
Reported: 2011-07-01 01:10 PDT by Adam Barth
Modified: 2012-06-18 13:00 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.09 KB, patch)
2011-07-01 01:13 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (9.42 KB, patch)
2012-06-14 22:31 PDT, Dirk Pranke
no flags Details | Formatted Diff | Diff
Patch (10.88 KB, patch)
2012-06-15 14:48 PDT, Dirk Pranke
abarth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2011-07-01 01:10:56 PDT
new-run-webkit-tests output gets confused when logging
Comment 1 Adam Barth 2011-07-01 01:13:09 PDT
Created attachment 99443 [details]
Patch
Comment 2 Eric Seidel (no email) 2011-07-01 01:17:31 PDT
Comment on attachment 99443 [details]
Patch

OK.  How do we test this?
Comment 3 Adam Barth 2011-07-01 01:31:00 PDT
> OK.  How do we test this?

Dunno.  It actually fails in a different way.  :(
Comment 4 Dirk Pranke 2011-07-01 15:59:59 PDT
There are actually unit tests for this module (metered_stream_unittest.py). You can at least update them with what the expected behavior would be.

I'm not surprised if it is failing in a different way, because I remember having to play with the ordering once or twice to get it to even mostly work.

One solution would be to route all logging from the workers to the master so that it could coordinate the cursor state. I looked into doing that once (when we were getting duplicate messages in the log from the workers) but only got about halfway through before I realized the problem was actually that there were two loggers running in that case.

Another (presumably much less portable) option would be to push the MeteredStream's state into some form of shared memory.
Comment 5 Adam Barth 2011-07-01 16:30:24 PDT
Comment on attachment 99443 [details]
Patch

Logging in NRWT is way too complicated.  I'd prefer to just do something simpler.
Comment 6 Dirk Pranke 2012-06-08 18:59:18 PDT
*** Bug 67164 has been marked as a duplicate of this bug. ***
Comment 7 Dirk Pranke 2012-06-14 22:31:48 PDT
Created attachment 147733 [details]
Patch
Comment 8 Dirk Pranke 2012-06-15 14:48:51 PDT
Created attachment 147902 [details]
Patch
Comment 9 Adam Barth 2012-06-18 11:52:21 PDT
Comment on attachment 147902 [details]
Patch

I don't really understand python logging enough to really understanding this patch.  Are you looking for a real review or just a rubber stamp?
Comment 10 Adam Barth 2012-06-18 12:10:43 PDT
Comment on attachment 147902 [details]
Patch

dpranke told me in #webkit that he's just look for an rs here, which I'm happy to provide.
Comment 11 Dirk Pranke 2012-06-18 13:00:07 PDT
Committed r120619: <http://trac.webkit.org/changeset/120619>