Bug 67164 - [nrwt] Broken output when writing new test results
Summary: [nrwt] Broken output when writing new test results
Status: RESOLVED DUPLICATE of bug 63793
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-29 16:19 PDT by Alexey Proskuryakov
Modified: 2012-06-08 18:59 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2011-08-29 16:19:16 PDT
This is the output that I'm currently getting from NRWT on Lion (there is a test landed without results):

  compositing/tiling/crash-reparent-tiled-layer.html -> unexpected text diff mismatch
  http/tests/appcache/origin-usage.html -> unexpected text diff mismatch
  css2.1/t0602-c13-inheritance-00-e.html -> unexpected text diff mismatch
  http/tests/cookies/simple-cookies-max-age.html -> unexpected text diff mismatch
  canvas/philip/tests/2d.path.stroke.prune.arc.html -> unexpected text diff mismatch
  fast/canvas/webgl/canvas-test.html -> unexpected text diff mismatch
Testing (38%): 10203 ran as expectedWriting new expected result "fast/exclusions/triangle-exclusion-expected.txt"
  fast/exclusions/triangle-exclusion.html -> unexpected no expected result found
  fast/files/create-blob-url-crash.html -> unexpected text diff mismatch
  fast/text/complex-preferred-logical-widths.html -> unexpected text diff mismatch
  fast/text/hyphenate-locale.html -> unexpected text diff mismatch

The line for "Writing new expected result" looks wrong.
Comment 1 Dirk Pranke 2011-08-29 16:26:27 PDT
By "looks wrong" I'm guessing you mean that there should've been a carriage return in between "expected" and "Writing"?

This is a known flaw in the way stuff gets logged to stderr in NRWT by default; messages in the worker processes interleave with the "progress meter" in the manager process.

We have not bothered to implement the "general" solution that would coordinate messages between processes; the hack we normally employ is to print a blank line before printing messages from the workers. Such a hack is a trivial fix.
Comment 2 Dirk Pranke 2012-06-08 18:59:18 PDT
this is actually a duplicate of 63793.

*** This bug has been marked as a duplicate of bug 63793 ***