findNextLineBreak is an ancient function and violates almost all WebKit style guides. We should cleanup this function and split it into smaller pieces.
Changing the name because there's lots of good refactoring to be done in that entire file.
I want to split most of the code in this file off into a new class called LineBoxTree. Basically RenderBlock should be *much* simpler than it is today, and all of the line-box-tree related code should move into a new LineBoxTree class which it has one of as a m_lineboxTree member.