Bug 47369 - REGRESSION(r67568-r67643): Some HTML/CSS renders upside down and backwards on Leopard
Summary: REGRESSION(r67568-r67643): Some HTML/CSS renders upside down and backwards on...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P1 Normal
Assignee: Simon Fraser (smfr)
URL: http://www.apple.com/ipad/pompeii/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-10-07 12:42 PDT by Edward Sabol
Modified: 2010-10-22 10:14 PDT (History)
6 users (show)

See Also:


Attachments
Patch (18.22 KB, patch)
2010-10-20 10:09 PDT, Simon Fraser (smfr)
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Sabol 2010-10-07 12:42:40 PDT
I was using the latest Webkit Nightly when I noticed that http://www.apple.com/ipad/pompeii/ wasn't rendering correctly. The "iPad Apps They Used" sidebar on the right renders upside down and backwards, and the large picture and picture-nagivation interface which should be at the top of the web page renders upside down and at the bottom of the web page instead of the top. This is apparently a PowerPC-only problem. I had someone #webkit check it for me on Intel using a recent Webkit Nightly build, and he didn't see any problem. Using the Webkit Nightly builds, I've narrowed down the regression to be between r67568 (which renders correctly) and r67643 (which renders incorrectly). I hope someone can use git-bisect to further narrow down the regression to a specific revision.
Comment 1 Simon Fraser (smfr) 2010-10-08 12:01:54 PDT
Broken by http://trac.webkit.org/changeset/67576
Comment 2 Simon Fraser (smfr) 2010-10-08 12:02:48 PDT
I think this is a Leopard issue, rather than a PPC issue.
Comment 3 Simon Fraser (smfr) 2010-10-08 12:03:16 PDT
<rdar://problem/8530595>
Comment 4 Simon Fraser (smfr) 2010-10-19 10:52:35 PDT
This is an interaction with the code added for bug 48401, so it's only apparent on pages over 2048px tall.
Comment 5 Simon Fraser (smfr) 2010-10-19 11:19:04 PDT
Previous comment should have referred to bug 27272, which resulted in r48401.
Comment 6 Simon Fraser (smfr) 2010-10-20 07:59:13 PDT
*** Bug 45971 has been marked as a duplicate of this bug. ***
Comment 7 Simon Fraser (smfr) 2010-10-20 10:09:58 PDT
Created attachment 71302 [details]
Patch
Comment 8 Simon Fraser (smfr) 2010-10-20 13:08:10 PDT
http://trac.webkit.org/changeset/70166
Comment 9 WebKit Review Bot 2010-10-20 13:27:27 PDT
http://trac.webkit.org/changeset/70166 might have broken Qt Linux Release
Comment 10 Kevin M. Dean 2010-10-22 10:14:15 PDT
My Bug 45971 was resolved as duplicate of this one, but something introduced with r70098 is breaking things entirely and I don't know if it's unrelated or if this patch fixes anything.

Using Youtube's HTML5 setting, videos no longer appear at all and the video thumbnails don't appear. Read my original bug for more details. The latest glitch started with r70098 and continues with r70284.