Bug 46569 - Flash + downloading the file bug resubmitted
Summary: Flash + downloading the file bug resubmitted
Status: RESOLVED DUPLICATE of bug 46380
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-25 11:12 PDT by Sveto
Modified: 2010-09-27 11:12 PDT (History)
1 user (show)

See Also:


Attachments
Crash log report (86.68 KB, text/plain)
2010-09-27 10:40 PDT, Sveto
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sveto 2010-09-25 11:12:24 PDT
As requested I'm resubmitting the bug with more details. As of the build before r68204 I started noticing following regression. As an example:
go to www.bnt.bg
select any of the Flash videos available there 
let it start running
go to Activity and find the actual link of the video
double click on the so it starts to download the video.
Basically you have the video running in the main window and you attempt to download the same video in the same time. Once Webkit tries to initiate the download it crashes. Before the build in question it was working as supposed, one could watch the video and in the same time download it.
Comment 1 Alexey Proskuryakov 2010-09-25 15:40:02 PDT
Could you please clarify who requested to re-submit the bug? What is the reason to believe that this is not a duplicate of bug 46380?
Comment 2 Sveto 2010-09-26 15:51:54 PDT
I was under the impression you requested a resubmission, but now I realize it might have not been directed to me. In any event, I personally am stopping the testing of Webkit builds until that thing is resolved. It is extremely annoying and I breaks my working process.
Just to help you out one last time. Build r67838 is the first one not to have this bug, but caries with it yet another really annoying bug when logging in into Hotmail. So the way it stands right now I downgraded to r68077 which luckily has no easily notable bugs. I think I'll keep it for now until you guys sort out the problems. Right now, webkit is full of bugs and that can drive one nuts. Sorry
Comment 3 Alexey Proskuryakov 2010-09-26 18:20:18 PDT
OK, so here is what happened. The original bug you submitted was bug 46441, and it was closed as a duplicate of bug 46380. You were automatically added to CC list of the latter bug as a result.

The request to re-submit that I made was to the original reporter of bug 46380, not to you. Sorry for the confusion. The crashing bug has been fixed a few days ago, you shouldn't see it with the latest nightly. If you are seeing some bug with Hotmail in the latest nightly (or if you're actually still seeing a crash when downloading Flash movies), please let us know. 

For Hotmail, the best thing to do would be to file a new bug; for crashing on download, please feel free to re-open this one.

*** This bug has been marked as a duplicate of bug 46380 ***
Comment 4 Sveto 2010-09-27 10:40:41 PDT
Created attachment 68929 [details]
Crash log report
Comment 5 Sveto 2010-09-27 10:41:25 PDT
Ok, the good news, in r68242 that bug with Hotmail has been resolved.
The bad news r68242 crashes on downloading flash movies like there is no tomorrow! See my instructions how to reproduce. Furthermore it crashes on some dynamically generated downloads like the once generated by Apple. A perfect example (completely reproducible) is if you go to apple's page and try to download latest iTunes 10. Once it starts the download Webkit crashes on the spot. Mind you I have no extensions installed, in fact I have the extensions option completely disabled. My Safari is plain vanilla. r68242 is the latest build and it has the crashing bug far from being resolved! Again the last really stable build was r67077. I have zero problems with that one.
I'm attaching the crash report generated when trying to download iTunes 10 and when trying to download a flash movie. Both reports are into the same text file and are separated by some space for clarity.
Comment 6 Alexey Proskuryakov 2010-09-27 11:12:47 PDT
The crashing bug has been fixed in r68266. Unfortunately, the latest nightly we currently have is r68242, which doesn't contain the fix yet.

*** This bug has been marked as a duplicate of bug 46380 ***