Bug 4396 - REGRESSION: pressing back button won't work @gmail.com
Summary: REGRESSION: pressing back button won't work @gmail.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: History (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: GoogleBug, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2005-08-11 16:38 PDT by Christian Junker
Modified: 2007-11-17 20:50 PST (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Junker 2005-08-11 16:38:49 PDT
If I open up a specific email and read it till the end, I want to go back to my Inbox folder, which is done 
by pressing the back button. However, on Safari this does not work right, the following occurs:
1.) Gmail states that it's loading data at the top right in a visual red box
2.) all the time the page remains to be completely blank except the red box (->1.)).

So what I need to do as a workaround to get into my inbox again is either clicking Inbox or reloading 
the gmail site which instantly opens up the main view (Inbox).

general comment:
Safari seems to really have some problems with Gmail, is that because JavaScript is not flawlessly 
integrated into the browser? (Gmail heavily uses Javascript to do all the visual stuff)
Comment 1 Oliver Hunt 2005-09-07 05:22:36 PDT
back button works as expected in ffx/mac currently ToT is completely broken wrt gmail though..
Comment 2 David Kilzer (:ddkilzer) 2006-07-12 21:55:24 PDT
If GMail was expecting URL hashes (#foo, #bar, etc.) to appear in history to do this, this bug may now be fixed since Bug 6309 landed.

Comment 3 David Kilzer (:ddkilzer) 2006-07-12 21:58:17 PDT
GMail is Google.

Comment 4 Antti Koivisto 2007-04-04 03:26:46 PDT
In Firefox you get nicely back to the mail main view. In shipping Safari you just get back to previous page you were before going to GMail. In ToT you get endless "Loading..." page. 

This is a Google regression and should be P1.
Comment 5 Darin Adler 2007-04-25 09:40:58 PDT
<rdar://problem/5159418>
Comment 6 David Kilzer (:ddkilzer) 2007-06-22 10:53:01 PDT
See misplaced comment in Bug 9930 Comment #9.

Comment 7 David Kilzer (:ddkilzer) 2007-06-22 10:53:43 PDT
(In reply to comment #6)
> See misplaced comment in Bug 9930 Comment #9.

Bug 9930 Comment #9 From Maxime BRITTO 2007-06-22 07:45 PDT
On safari 3beta / r23737.
When I press back button while reading a mail I come back to the page just
before my InBox (the login page)
Comment 8 Maciej Stachowiak 2007-06-28 22:03:57 PDT
Sounds like this is resolved.
Comment 9 Graeme Rocher 2007-08-17 06:24:24 PDT
This is not resolved as of today's nightly webkits. As a frequent Gmail user this is the major thing stopping me from using Safari/Webkit as Gmail has become a critical app for me. Please fix it.
Comment 10 Graeme Rocher 2007-08-17 06:26:34 PDT
Oops, seems I may have marked it as resolved/fixed by accident, can someone re-open? You guys need to use JIRA ;-)
Comment 11 David Kilzer (:ddkilzer) 2007-08-17 08:14:43 PDT
Reopening per Comment #10.

Comment 12 David Kilzer (:ddkilzer) 2007-08-17 08:42:10 PDT
I believe this is an issue where setting iframe.src (Bug 9145) or frame.src (Bug 9166) is not registered in history.  I think Gmail uses framesets.

Note that setting iframe.contentDocument.location (as opposed to iframe.src) does register in history with ToT WebKit, so this could be a solution for Google until WebKit supports history when setting frame.src.
Comment 13 Darren Collins 2007-09-20 19:18:43 PDT
This works for me on Windows r25668.  It worked at least as far back as r24749 on Windows.  Earlier versions like Windows r24256 just did nothing when back button pressed.
I have not tested on a Mac.
Comment 14 Stephen Harbage 2007-11-17 08:16:20 PST
Fixed in Safari 3.0.4 and Gmail's new interface! : )

It's great when bugs get fixed!... Time to close it?
Comment 15 David Kilzer (:ddkilzer) 2007-11-17 20:50:29 PST
Closing as this works in the new GMail interface per Comment #14 (and also tested by me).

Note that Bug 9145 (which was duped to Bug 9166) was the original reason why this didn't work in GMail.  That issue still has not been fixed, though.  See Bug 9166 Comment #7 for more information about this.