The comments here need to be addressed: https://bugs.webkit.org/show_bug.cgi?id=40084#c14
Created attachment 59380 [details]
Comment on attachment 59380 [details]
> -FormSubmission::FormSubmission(Method method, const KURL& action, const String& target, const String& contentType, PassRefPtr<FormState> state, PassRefPtr<FormData> data, const String& boundary, bool lockHistory, PassRefPtr<Event> event)
I suggest just adding the "inline" keyword in front of this constructor definition. Since it's only used in the create function, there's no need to move it to the header. Also, the version in the header uses formatting that is not standard for WebKit, not indenting the member initializer list.
Ha! My clean-up patch manages to need its own fixups. Sorry for such a rush job. Will fix and land as you suggested.
Folded into bug 41110.