Bug 3751 - REGRESSION: affects Blogger, GMail & Wikipedia: empty textarea's which should have content
: REGRESSION: affects Blogger, GMail & Wikipedia: empty textarea's which should...
Status: RESOLVED FIXED
: WebKit
New Bugs
: 412
: Macintosh Mac OS X 10.4
: P1 Critical
Assigned To:
: http://en.wikipedia.org/w/index.php?t...
:
:
:
  Show dependency treegraph
 
Reported: 2005-06-28 18:06 PST by
Modified: 2005-07-19 20:54 PST (History)


Attachments
Test Case (628 bytes, text/html)
2005-07-04 01:11 PST, Chad Ingram
no flags Details
Fix bug (3.87 KB, patch)
2005-07-05 03:13 PST, Anders Carlsson
mjs: review-
Review Patch | Details | Formatted Diff | Diff
Address comments (2.60 KB, patch)
2005-07-08 15:20 PST, Anders Carlsson
andersca: review-
Review Patch | Details | Formatted Diff | Diff
Call updateValue (2.51 KB, patch)
2005-07-08 16:46 PST, Anders Carlsson
mjs: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-28 18:06:46 PST
With the last version of WebKit (June 28), if you try to edit some pages on Wikipedia you obtain a blank 
form (see the linked URL).

The form should contain the current revision of the article instead. Some pages, like

http://en.wikipedia.org/w/index.php?title=Current_events&action=edit

work correctly. This bug was not present in the last official version of WebKit (412).
------- Comment #1 From 2005-06-29 01:12:30 PST -------
Confirmed, marked p1 and major since it's a major site and thus a major problem :P
------- Comment #2 From 2005-06-29 12:06:40 PST -------
I've noticed another quite strange thing about this bug.
The content of the form appears if you do the following:

1 - Click on the background of the page
2 - Reload the page
(If you just reload immediately after loading, or if you click on the form then reload this doesn't work)

This could be useful if someone wants to edit Wikipedia pages before the bug is fixed.
------- Comment #3 From 2005-06-29 14:06:24 PST -------
This also seems to be affecting Backpack. Clicking "Edit" on any element results in an empty field.
------- Comment #4 From 2005-06-30 11:23:35 PST -------
*** Bug 3772 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2005-07-01 05:23:42 PST -------
*** Bug 3785 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2005-07-01 05:25:11 PST -------
This one get's reported more, please look into it, as it is breaking some major sites.
------- Comment #7 From 2005-07-04 01:10:42 PST -------
Affects Gmail too, changing summary.
------- Comment #8 From 2005-07-04 01:11:29 PST -------
Created an attachment (id=2782) [details]
Test Case
------- Comment #9 From 2005-07-04 01:54:57 PST -------
Affects every Mambo CMS generated site too.
------- Comment #10 From 2005-07-04 02:38:38 PST -------
Affects Gmail when replying to an e-mail. Address box blank: should be pre-filled with recipient.
------- Comment #11 From 2005-07-04 20:11:11 PST -------
Just pulled the latest code (July 5th) and still not fixed. For people thinking of updating their webkit, stay 
clear of this unless you are not using Gmail, or other JS text area related sites.
------- Comment #12 From 2005-07-05 00:11:04 PST -------
Testcase crashes Safari when you click on the page. This one get's nicer and nicer :)
------- Comment #13 From 2005-07-05 02:02:15 PST -------
terminal always shows 
/Users/matrix9180/WebCore/khtml/xml/dom_position.cpp:494: failed assertion `currentPos == start'
Abort trap

when it crashes
------- Comment #14 From 2005-07-05 03:13:09 PST -------
Created an attachment (id=2803) [details]
Fix bug
------- Comment #15 From 2005-07-05 03:19:03 PST -------
(In reply to comment #13)
> terminal always shows 
> /Users/matrix9180/WebCore/khtml/xml/dom_position.cpp:494: failed assertion `currentPos == start'
> Abort trap
> 
> when it crashes

This assertion failure also shows in bug 3624.
------- Comment #16 From 2005-07-06 07:31:33 PST -------
The attached patch is working in GMail. Cheers guys.
------- Comment #17 From 2005-07-06 13:13:22 PST -------
I can also confirm that the patch works with Gmail, and (thankfully) Backpack too.
------- Comment #18 From 2005-07-08 15:20:29 PST -------
Created an attachment (id=2870) [details]
Address comments
------- Comment #19 From 2005-07-08 15:45:11 PST -------
(From update of attachment 2870 [details])
This breaks some of the layout tests.
------- Comment #20 From 2005-07-08 16:46:29 PST -------
Created an attachment (id=2871) [details]
Call updateValue

We need to call updateValue, otherwise we'll have the same problem when
setValue calls updateFromElement
------- Comment #21 From 2005-07-08 18:08:50 PST -------
(From update of attachment 2871 [details])
r=me
------- Comment #22 From 2005-07-09 07:42:45 PST -------
Don't know if the patch was pulled, but the 0708 and 0709 builds are regressing back to the old, broken 
behaviour.
------- Comment #23 From 2005-07-10 17:11:10 PST -------
Neil, it was never applied - AFAIK the patch is still in review, and hasn't been merged with ToT. Those of 
us reporting success have applied the patch manually.
------- Comment #24 From 2005-07-19 20:54:35 PST -------
Why has this been marked as fixed? A build I pulled and compiled 5 minutes ago still has this issue.