Bug 33372 - REGRESSION(r52976): platform/mac/editing/input/devanagari-ligature.html is failing on Snow Leopard Release
Summary: REGRESSION(r52976): platform/mac/editing/input/devanagari-ligature.html is fa...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 32294
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-08 03:06 PST by Eric Seidel (no email)
Modified: 2012-10-27 18:28 PDT (History)
4 users (show)

See Also:


Attachments
reduced test case (restart Safari to test) (433 bytes, text/html)
2010-01-11 11:17 PST, Alexey Proskuryakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2010-01-08 03:06:07 PST
REGRESSION(r52976): platform/mac/editing/input/devanagari-ligature.html is failing on Snow Leopard Release

--- layout-test-results/platform/mac/editing/input/devanagari-ligature-expected.txt	2010-01-08 00:05:31.000000000 -0800
+++ layout-test-results/platform/mac/editing/input/devanagari-ligature-actual.txt	2010-01-08 00:05:31.000000000 -0800
@@ -4,6 +4,6 @@
   RenderBlock {HTML} at (0,0) size 800x600
     RenderBody {BODY} at (8,8) size 784x584
       RenderBlock {DIV} at (0,0) size 784x19
-        RenderText {#text} at (0,1) size 11x18
-          text run at (0,1) width 11: "\x{915}\x{94D}\x{937}"
+        RenderText {#text} at (0,1) size 21x18
+          text run at (0,1) width 21: "\x{915}\x{94D}\x{937}"
 caret: position 3 of child 0 {#text} of child 1 {DIV} of child 1 {BODY} of child 0 {HTML} of document

I expect this is the same kind of bug as bug 32294.

Unfortunately I do not have a Snow Leopard box, so I can't reproduce this.  Someone else will have to find out what test was affecting platform/mac/editing/input/devanagari-ligature.html.

To do so, I recommend:

1.  Confirm that running platform/mac/editing/input/devanagari-ligature.html by itself "fails" (in this case, it was previously being affected by an http or websocket test and we didn't notice)

in this case, the currently checked in result is incorrect, and we need to figure out which test before devanagari-ligature.html is affecting it to cause this failure.

2.  Assuming it failed when run alone, check out r52975.

Figure out what 1000 tests are run prior to devanagari-ligature.html.  To do that:

3.  run-webkit-tests -v
4.  Select all tests output lines prior to and including platform/mac/editing/input/devanagari-ligature.html
5.  pbpaste | awk '{ print $2 }' | tail -n 1000  > failing_set.txt  will write the 1000 tests prior to (and including platform/mac/editing/input/devanagari-ligature.html)
6.  cat failing_set.txt | xargs run-webkit-tests   and confirm that those tests still "pass"

Now to find out which test or tests is affecting devanagari-ligature.html, do:

7. Remove some tests from failing_set.txt
8.  re-run cat failing_set.txt | xargs run-webkit-tests
9. if run-webkit-tests exits non-zero ("fails") then we've removed too many, go back to step 7 remove different tests, otherwise remove more tests until you can't remove any more.

Tada!

At least that's the methodology I used to figure out bug 32294, which again, I believe to be a similar cause.
Comment 1 Eric Seidel (no email) 2010-01-08 12:15:53 PST
I've learned from Beth Dakin that:
run-webkit-tests --skipped=ignore platform/mac/editing/input/devanagari-ligature.html
passes on her Snow Leopard machine.  That suggests that the checked in results are correct, and now there is some other factor causing this to fail with the new ordering.
Comment 2 Alexey Proskuryakov 2010-01-08 17:55:19 PST
The actual result I get when running all tests is an outright failure.
Comment 3 Eric Seidel (no email) 2010-01-09 14:58:01 PST
I finally got XCode installed and WebKit built on my personal SL machine.  I'll take a look at this again next time I'm WFH.  I do not have access to a SL machine at work.
Comment 4 Eric Seidel (no email) 2010-01-10 20:56:01 PST
These 7 test cases together seem to cause the failure:

fast/text/international/danda-space.html
fast/text/international/hindi-spacing.html
fonts/monospace.html
fonts/sans-serif.html
fonts/serif.html
platform/mac/editing/deleting/backward-delete.html
platform/mac/editing/input/devanagari-ligature.html

Removing any one test case seems to cause the test to pass.  I'm not really sure what's going on here.  I expect this may be related to bug 33400 since they were both revealed by the same test re-ordering.
Comment 5 Alexey Proskuryakov 2010-01-11 11:17:54 PST
Created attachment 46291 [details]
reduced test case (restart Safari to test)
Comment 6 Ryosuke Niwa 2010-09-28 09:09:38 PDT
This bug does not seem to reproduce anymore on TOT.  Can we add the attached test case as a regression test and close the bug?
Comment 7 Alexey Proskuryakov 2010-09-28 09:31:39 PDT
Sounds reasonable. But the test will probably be too machine-dependent, with all these fonts used in it. Perhaps it should be converted into a text-only test for landing.
Comment 8 Ryosuke Niwa 2010-10-05 15:25:46 PDT
Oops, test still fails on TOT.  Reduction gives me

          text run at (0,1) width 214: "This should be a single character: "
        RenderInline {SPAN} at (0,0) size 11x18
          RenderText {#text} at (214,1) size 11x18
            text run at (214,1) width 11: "\x{915}\x{94D}\x{937}"

but

WebKitTools/Scripts/run-webkit-tests --debug fast/text/international/danda-space.html fast/text/international/hindi-spacing.html fonts/monospace.html fonts/sans-serif.html fonts/serif.html platform/mac/editing/deleting/backward-delete.html platform/mac/editing/input/devanagari-ligature.html

fails. We probably made it harder to reproduce :(
Comment 9 Eric Seidel (no email) 2012-10-27 12:06:02 PDT
I believe the SL port is dead for AppleMac and this can be closed.  Please re-open if I'm mistaken.
Comment 10 Alexey Proskuryakov 2012-10-27 17:26:53 PDT
I don't have a build to test on this machine, but from reading this bug, I don't see evidence that this got fixed. In January 2010, Snow Leopard was the latest release.