Bug 33400 - Font fallback kills SVG kerning
Summary: Font fallback kills SVG kerning
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 33374
  Show dependency treegraph
 
Reported: 2010-01-08 14:07 PST by Alexey Proskuryakov
Modified: 2010-01-09 10:47 PST (History)
4 users (show)

See Also:


Attachments
test case (3.39 KB, application/zip)
2010-01-08 14:07 PST, Alexey Proskuryakov
no flags Details
Cache font attributes seperately for different typesetting features (86.02 KB, patch)
2010-01-09 02:38 PST, mitz
zimmermann: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2010-01-08 14:07:25 PST
Created attachment 46159 [details]
test case

Steps to reproduce:
1. Unpack the attached archive into LayoutTests directory.
2. run-webkit-tests --pixel --tolerance 0 kerning/2.svg
3. run-webkit-tests --pixel --tolerance 0 kerning

Results: 2.svg fails, because kerning doesn't happen.
Comment 1 mitz 2010-01-09 00:48:31 PST
<rdar://problem/7525778>
Comment 2 mitz 2010-01-09 02:38:20 PST
Created attachment 46203 [details]
Cache font attributes seperately for different typesetting features
Comment 3 Nikolas Zimmermann 2010-01-09 06:27:47 PST
Comment on attachment 46203 [details]
Cache font attributes seperately for different typesetting features

Looks very nice! I assume you've tried a pixel test run in svg/ as well, without problems? If yes, r=me.
Comment 4 David Kilzer (:ddkilzer) 2010-01-09 08:42:21 PST
Comment on attachment 46203 [details]
Cache font attributes seperately for different typesetting features

> +        Cache font attributes seperately for different typesetting features.

Typo:  "separately"
Comment 5 David Kilzer (:ddkilzer) 2010-01-09 08:51:42 PST
Comment on attachment 46203 [details]
Cache font attributes seperately for different typesetting features

> +        (WebCore::SimpleFontData::getCFStringAttributes): Look up the attributes
> +        dictionary in the map and initialize in necessary.

Typo: "if necessary".
Comment 6 mitz 2010-01-09 10:47:35 PST
Fixed in <http://trac.webkit.org/projects/webkit/changeset/53039>.