Bug 28916 - patches marked cq+ without review will hang the commit-queue
: patches marked cq+ without review will hang the commit-queue
Status: RESOLVED DUPLICATE of bug 28605
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-02 13:03 PDT by Eric Seidel
Modified: 2009-09-08 14:11 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel 2009-09-02 13:03:15 PDT
patches marked cq+ without review will hang the commit-queue

The queue spins infinitely.  It thinks it has something to land, but then when it goes to land it, it doesn't find a patch and thus it just loops indefinitely. :(
Comment 1 Eric Seidel 2009-09-02 13:03:35 PDT
https://bugs.webkit.org/show_bug.cgi?id=28887 caused the hang this evening.
Comment 2 Eric Seidel 2009-09-08 14:11:50 PDT
This will be fixed by the patch on bug 28605.  The fix was to make the commit queue call the fetch_patches_from_commit_queue up front instead of fetch_bug_ids_from_commit_queue so that it is sure to validate the patches before passing them off to land-patches.

*** This bug has been marked as a duplicate of bug 28605 ***