Bug 26920 - bugzilla-tool dumps too much junk the the commit comment from git
Summary: bugzilla-tool dumps too much junk the the commit comment from git
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 27949 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-02 00:05 PDT by Eric Seidel
Modified: 2009-08-17 15:18 PDT (History)
2 users (show)

See Also:


Attachments
Patch v1 (1.42 KB, patch)
2009-08-17 13:43 PDT, David Kilzer (:ddkilzer)
aroben: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel 2009-07-02 00:05:35 PDT
bugzilla-tool dumps too much junk the the commit comment from git

Only happens when the commit needs to rebase I  think.

Example:

Committing to http://svn.webkit.org/repository/webkit/trunk ...
        M       WebKitTools/ChangeLog
        M       WebKitTools/Scripts/bugzilla-tool
        M       WebKitTools/Scripts/modules/scm.py
Committed r45469
        M       WebCore/dom/MessageChannel.cpp
        M       WebCore/dom/MessagePortChannel.cpp
        M       WebCore/dom/default/PlatformMessagePortChannel.cpp
        M       WebCore/dom/MessagePortChannel.h
        M       WebCore/ChangeLog
r45467 = a08d526b1bd9d60aa510e837f37ef18283db029a (trunk)
        M       WebCore/ChangeLog
        M       WebCore/rendering/RenderLayerBacking.cpp
        A      
LayoutTests/platform/mac/compositing/geometry/root-layer-update-expected.png
        A      
LayoutTests/platform/mac/compositing/geometry/root-layer-update-expected.txt
        A      
LayoutTests/platform/mac/compositing/geometry/root-layer-update-expected.checksum
        M       LayoutTests/ChangeLog
        A       LayoutTests/compositing/geometry/root-layer-update.html
r45468 = 25496daa3193049bc58b8c6255dbdba7af72f00a (trunk)
        M       WebKitTools/ChangeLog
        M       WebKitTools/Scripts/modules/scm.py
        M       WebKitTools/Scripts/bugzilla-tool
r45469 = 21a28c8eebc35fcfe1b6453a264f3e208128e89c (trunk)
First, rewinding head to replay your work on top of it...
Nothing to do.
http://trac.webkit.org/changeset/45469
Comment 1 Mark Rowe (bdash) 2009-07-02 10:15:53 PDT
I don't think including the list of files that were committed is useful in any case.  The revision number (rXXXX) and a link to Trac are probably sufficient.
Comment 2 Eric Seidel 2009-07-06 19:31:11 PDT
Another victim of this bug! https://bugs.webkit.org/show_bug.cgi?id=27008
Comment 3 Eric Seidel 2009-08-03 13:35:39 PDT
*** Bug 27949 has been marked as a duplicate of this bug. ***
Comment 4 David Kilzer (:ddkilzer) 2009-08-17 13:37:24 PDT
Example of less-verbose commit message:

<https://bugs.webkit.org/show_bug.cgi?id=28393#c2>
Comment 5 David Kilzer (:ddkilzer) 2009-08-17 13:43:49 PDT
Created attachment 34989 [details]
Patch v1
Comment 6 Adam Roben (:aroben) 2009-08-17 13:45:21 PDT
Comment on attachment 34989 [details]
Patch v1

r=me
Comment 7 Eric Seidel 2009-08-17 13:56:13 PDT
Thanks.
Comment 8 David Kilzer (:ddkilzer) 2009-08-17 15:17:59 PDT
Committed r47393: <http://trac.webkit.org/changeset/47393>
Comment 9 David Kilzer (:ddkilzer) 2009-08-17 15:18:05 PDT
All reviewed patches have been landed.  Closing bug.